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Preface

Purpose

The Cisco CRS Servicing and Troubleshooting Guide provides instructions for using the CRS
Serviceability tools and helps you resolve any problems you might experience with the CRS

system.

The Cisco CRS Servicing and Troubleshooting Guide is written for administrators and others
who are responsible for managing and troubleshooting the Cisco CRS system.

This guide consists of two parts:

» Part 1: Serviceability

» Part 2: Troubleshooting

Part 1 consists of the following chapters:

Chapter |Title Description

Chapter 1 | About Serviceability Provides an overview of the Cisco CRS serviceability
support and the support provided when an expansion
server is used.

Chapter 2 |Simple Network Describes how you can use SNMP to monitor and

Management Protocol
Support (SNMP)

manage your CRS system.
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Related Documentation

Chapter |Title Description

Chapter 3 | Alarm Service Describes how to configure the Cisco AVVID Alarm
Service and view alarm messages.

Chapter 4 |Trace Describes how to configure the component trace file,
set trace level options, and view and interpret trace
log files.

Chapter 5 |Cisco Discovery Protocol |Describes how to use the CDP Driver, view the CDP
Support (CDP) Driver properties, and locate the CDP Driver and
interface files.

Part 2 consists of the following chapters:

Chapter |Title Description

Chapter 6 | Diagnosing and Provides steps that can help you troubleshoot most
Correcting Cisco CRS | problems with your Cisco CRS system.
Problems

Chapter 7 | Troubleshooting Provides troubleshooting tips for the various elements

of the CRS system. Each tip contains the symptom of
a problem, the possible cause of the problem, and the
corrective action for the problem. The tips are grouped
by category.

The Index helps you find information in this guide.

Related Documentation

You might also need the following documents:
» Cisco CRSAdministration Guide

» Cisco CAD Service Information Guide

+ Cisco CRS Database Schema

» Cisco CRS Getting Started with Scripts

» Cisco CRSEditor Sep Reference

» Cisco CRSHistorical Reports User Guide

» Cisco IPCC Gateway Deployment Guide

Cisco Customer Response Solutions Servicing and Troubleshooting Guide 4.0(x)
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Obtaining Documentation

Obtaining Documentation

Cisco.com

Cisco documentation and additional literature are available on Cisco.com. Cisco also provides
several ways to obtain technical assistance and other technical resources. These sections explain
how to obtain technical information from Cisco Systems.

You can access the most current Cisco documentation at this URL:

http://www.cisco.com/techsupport

You can access the Cisco website at this URL:

http://www.cisco.com

You can access international Cisco websites at this URL:

http://www.cisco.com/public/countries languages.shtml

Product Documentation DVD

Cisco documentation and additional literature are available in the Product Documentation DVD
package, which may have shipped with your product. The Product Documentation DVD is
updated regularly and may be more current than printed documentation.

The Product Documentation DVD is a comprehensive library of technical product documentation
on portable media. The DVD enables you to access multiple versions of hardware and software
installation, configuration, and command guides for Cisco products and to view technical
documentation in HTML. With the DVD, you have access to the same documentation that is
found on the Cisco website without being connected to the Internet. Certain products also have
.pdf versions of the documentation available.

The Product Documentation DVD is available as a single unit or as a subscription. Registered
Cisco.com users (Cisco direct customers) can order a Product Documentation DVD from the
Ordering tool or Cisco Marketplace.

Cisco Ordering Tool:

http://www.cisco.com/en/US/partner/ordering/

Cisco Marketplace:

http://www.cisco.com/go/mar ketplace/
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Documentation Feedback

Ordering Documentation

Beginning June 30, 2005, registered Cisco.com users may order Cisco documentation at the
Product Documentation Store in the Cisco Marketplace at this URL.::

http://www.cisco.com/go/mar ketplace/

Cisco will continue to support documentation orders using the Ordering tool:

» Registered Cisco.com users (Cisco direct customers) can order Cisco product documentation
from the Ordering tool:

http://www.cisco.com/en/US/partner/ordering/

« Instructions for ordering documentation using the Ordering tool are at this URL.:

http://www.cisco.com/univer cd/cc/td/doc/es inpck/pdi.htm

» Nonregistered Cisco.com users can order documentation through a local account representative
by calling Cisco Systems Corporate Headquarters (California, USA) at 408 526-7208 or,
elsewhere in North America, by calling 1 800 553-NETS (6387).

Documentation Feedback

You can rate and provide feedback about Cisco technical documents by completing the online
feedback form that appears with the technical documents on Cisco.com.

You can rate and provide feedback about Cisco technical documents by completing the online
feedback form that appears with the technical documents on Cisco.com.

You can submit comments by using the response card (if present) behind the front cover of your
document or by writing to the following address:

Cisco Systems Attn: Customer Document Ordering 170 West Tasman Drive San Jose, CA
95134-9883

We appreciate your comments.

Cisco Product Security Overview

Cisco provides a free online Security Vulnerability Policy portal at this URL: http://
www.cisco.com/en/US/products/products _security vulnerability policy.html
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Cisco Product Security Overview
From this site, you can perform these tasks:
 Report security vulnerabilities in Cisco products.
+ Obtain assistance with security incidents that involve Cisco products.
* Register to receive security information from Cisco.

A current list of security advisories and notices for Cisco products is available at this URL:
http://www.cisco.com/go/psirt

If you prefer to see advisories and notices as they are updated in real time, you can access a
Product Security Incident Response Team Really Simple Syndication (PSIRT RSS) feed from
this URL: http://www.cisco.com/en/US/products/products psirt_rss feed.html

Reporting Security Problems in Cisco Products

Cisco is committed to delivering secure products. We test our products internally before we
release them, and we strive to correct all vulnerabilities quickly. If you think that you might
have identified a vulnerability in a Cisco product, contact PSIRT:

» Emergencies - security-alert@cisco.com

An emergency is either a condition in which a system is under active attack or a condition
for which a severe and urgent security vulnerability should be reported. All other conditions
are considered nonemergencies.

« Nonemergencies - psirt@cisco.com

In an emergency, you can also reach PSIRT by telephone:
e 1877 228-7302

» 1408 525-6532

Note: We encourage you to use Pretty Good Privacy (PGP) or a compatible product to encrypt
any sensitive information that you send to Cisco. PSIRT can work from encrypted information
that is compatible with PGP versions 2.x through 8.x. Never use a revoked or an expired
encryption key. The correct public key to use in your correspondence with PSIRT is the one
that has the most recent creation date in this public key server list:_http://pgp.mit.edu:11371/
pks/lookup?sear ch=psirt% 40cisco.com& op=index& exact=on

The link on this page has the current PGP key ID in use.

Cisco Customer Response Solutions Servicing and Troubleshooting Guide 4.0(x)

Preface 5


http://www.cisco.com/go/psirt
http://www.cisco.com/en/US/products/products_psirt_rss_feed.html
http://pgp.mit.edu:11371/pks/lookup?search=psirt%40cisco.com&op=index&exact=on
http://pgp.mit.edu:11371/pks/lookup?search=psirt%40cisco.com&op=index&exact=on

Preface

Obtaining Technical Assistance

Obtaining Technical Assistance

Cisco Technical Support provides 24-hour-a-day award-winning technical assistance. The Cisco
Technical Support & Documentation website on Cisco.com features extensive online support
resources. In addition, if you have a valid Cisco service contract, Cisco Technical Assistance
Center (TAC) engineers provide telephone support. If you do not have a valid Cisco service
contract, contact your reseller.

Cisco Technical Support & Documentation \Website

The Cisco Technical Support & Documentation website provides online documents and tools
for troubleshooting and resolving technical issues with Cisco products and technologies. The
website is available 24 hours a day, at this URL:

http://www.cisco.com/techsupport

Access to all tools on the Cisco Technical Support & Documentation website requires a
Cisco.com user ID and password. If you have a valid service contract but do not have a user ID
or password, you can register at this URL.:

http://tools.cisco.com/RPF/reqister /register.do

Note: Use the Cisco Product Identification (CPI) tool to locate your product serial number
before submitting a web or phone request for service. You can access the CPI tool from the
Cisco Technical Support Website by clicking the Tools & Resources Tools. Choose Cisco
Product I dentification Tool from the Alphabetical Index drop-down list, or click the Cisco
Product Identification Tool RMAs. The CPI tool offers three search options: by product 1D
or model name; by tree view; or for certain products, by copying and pasting show command
output. Search results show an illustration of your product with the serial number label location
highlighted. Locate the serial number label on your product and record the information before
placing a service call.

Submitting a Service Request

Using the online TAC Service Request Tool is the fastest way to open S3 and S4 service requests.
(S3 and S4 service requests are those in which your network is minimally impaired or for which
you require product information.) After you describe your situation, the TAC Service Request
Tool provides recommended solutions. If your issue is not resolved using the recommended
resources, your service request is assigned to a Cisco TAC engineer. The TAC Service Request
Tool is located at this URL:

http://www.cisco.com/techsuppor t/ser vicer equest

For S1 or S2 service requests or if you do not have Internet access, contact the Cisco TAC by
telephone. (S1 or S2 service requests are those in which your production network is down or
severely degraded.) Cisco TAC engineers are assigned immediately to S1 and S2 service requests
to help keep your business operations running smoothly
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Obtaining Additional Publications and Information
To open a service request by telephone, use one of the following numbers:

 Asia-Pacific: +61 2 8446 7411 (Australia: 1 800 805 227)

e EMEA: +322 7045555

» USA: 1800 553-2447

For a complete list of Cisco TAC contacts, go to this URL:

http://www.cisco.com/techsupport/contacts

Definitions of Service Request Severity

To ensure that all service requests are reported in a standard format, Cisco has established
severity definitions.

Severity 1 (S1) -- Your network is down, or there is a critical impact to your business operations.
You and Cisco will commit all necessary resources around the clock to resolve the situation.

Severity 2 (S2) -- Operation of an existing network is severely degraded, or significant aspects
of your business operation are negatively affected by inadequate performance of Cisco products.
You and Cisco will commit full-time resources during normal business hours to resolve the
situation.

Severity 3 (S3) -- Operational performance of your network is impaired, but most business
operations remain functional. You and Cisco will commit resources during normal business
hours to restore service to satisfactory levels.

Severity 4 (S4) -- You require information or assistance with Cisco product capabilities,
installation, or configuration. There is little or no effect on your business operations.

Obtaining Additional Publications and Information

Information about Cisco products, technologies, and network solutions is available from various
online and printed sources.

» Cisco Marketplace provides a variety of Cisco books, reference guides, and logo merchandise.
Visit Cisco Marketplace, the company store, at this URL:

http://www.cisco.com/go/mar ketplace/

» Cisco Press publishes a wide range of general networking, training and certification titles.
Both new and experienced users will benefit from these publications. For current Cisco Press
titles and other information, go to Cisco Press at this URL:

Cisco Customer Response Solutions Servicing and Troubleshooting Guide 4.0(x)
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http://www.Ciscopr ess.com

Packet magazine is the Cisco Systems technical user magazine for maximizing Internet and
networking investments. Each quarter, Packet delivers coverage of the latest industry trends,
technology breakthroughs, and Cisco products and solutions, as well as network deployment
and troubleshooting tips, configuration examples, customer case studies, certification and
training information, and links to scores of in-depth online resources. You can access Packet
magazine at this URL:

http://www.cisco.com/packet

iQ Magazine is the quarterly publication from Cisco Systems designed to help growing
companies learn how they can use technology to increase revenue, streamline their business,
and expand services. The publication identifies the challenges facing these companies and
the technologies to help solve them, using real-world case studies and business strategies to
help readers make sound technology investment decisions. You can access iQ Magazine at
this URL:

http://www.cisco.com/go/igmagazine

Internet Protocol Journal is a quarterly journal published by Cisco Systems for engineering
professionals involved in designing, developing, and operating public and private internets
and intranets. You can access the Internet Protocol Journal at this URL:

http://www.cisco.com/ipj

World-class networking training is available from Cisco. You can view current offerings at
this URL:

http://www.cisco.com/en/US/lear ning/index.html

Cisco Customer Response Solutions Servicing and Troubleshooting Guide 4.0(x)

Preface 8


http://www.ciscopress.com
http://www.cisco.com/packet
http://www.cisco.com/go/iqmagazine
http://www.cisco.com/ipj
http://www.cisco.com/en/US/learning/index.html

Part 1. Serviceability

Part 1 of this guide describes the serviceability support provided by Cisco Customer Response
Solutions (CRS).
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Chapter 1

About Serviceability

Cisco Customer Response Solutions (CRS) Serviceability enables remote network management
support for the Cisco CRS system. Serviceability enables this support through CiscoWorks and
through any third-party network management system (NMS) that uses standard protocols. These
protocols include Syslog, Simple Network Management Protocol (SNMP), XML, and HTTP.

Serviceability allows you to monitor and discover the status of the installed components of your
Cisco CRS system, its subsystems, and its services from any NMS. You can use the information
that you obtain through serviceability to troubleshoot system problems. (For additional
troubleshooting information, refer to Part 2 of this guide.)

Serviceability support includes:

SNMP Support—Provides integration with CiscoWorks or another SNMP-based network
management system (NMS). SNMP agents provide monitoring of network devices through
MIBs (Management Information Bases). For more information, see CiscoWorks Support
(page 12) and Simple Network Management Protocol Support (page 17).

SNMP Traps—Provides notification messages of high-severity Cisco CRS Engine errors.
For more information, see Simple Network Management Protocol Support (page 17)

Alarms—Use Alarms to obtain the run-time status and state of the Cisco CRS system and to
take corrective action to fix detected problems. You can forward alarms to a Syslog server,
to an SNMP trap subagent, or to a Windows Event Log. For more information, see Alarm
Service (page 31).

Trace—Provides specific, detailed Cisco CRS information for troubleshooting system
problems. You can also send alarms to a trace file for further analysis and you can specify
what level of event information is sent to the trace file. For more information, see Trace (page
39).

Cisco Discovery Protocol (CDP) Support—Sends messages containing system information
to a designated multicast address. For more information, see Cisco Discovery Protocol Support

(page 55).

Syslog Support—Sends common event logging messages in standard Syslog format to any
third-party Syslog server. For more information, see Alarm Service (page 31).
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About Serviceability

CiscoWorks Support

You can obtain additional system troubleshooting information using the following tools:

» CiscoWorks—Provides a suite of web-based applications for managing Cisco devices. For
more information, see CiscoWorks Support (page 12).

 Third-Party Network Management Systems—Provide Simple Network Management
Protocol-based browser, Syslog support, and other system management tools.

» Microsoft Windows 2000 Performance Monitoring—Allows you to monitor the performance
of the Cisco CRS system. For more information, refer to your Microsoft Windows
documentation.

» Microsoft Windows 2000 Terminal Service—Provides remote systems with access to
Windows-based applications through terminal emulation. Windows 2000 Server Terminal
Services are integrated with the Windows 2000 operating system. For more information,
refer to your Microsoft Windows documentation.

This section contains the following topics:

» CiscoWorks Support, page 12

» Syslog Support, page 13

» Remote Serviceability, page 13

» |IPCC Express Call Statistics, Recording, and Monitoring Server Serviceability Support, page
14

» Database Expansion Server Serviceability Support, page 14

CiscoWorks Support

CiscoWorks, available as a separate package, provides a suite of web-based applications for
managing Cisco devices. It is the network management system (NMS) of choice for the Cisco
CRS system and for other Cisco devices.

The Cisco CRS system integrates with these CiscoWorks applications:

+ |P Telephony Monitor—CiscoWorks IP Telephony Monitor (ITM) tracks the health of IP
telephony environments by proactively monitoring Cisco voice elements in the network to
alert operations personnel to potential problems and to help minimize IP telephony service
downtime.

» Resource Management Essentials (RME)—Provides tools for collecting Syslog messages
from multiple sources for system-level fault monitoring and analysis.

» Campus Manager—Provides network topology services, user tracking, and path analysis.
Campus Manager Topology Services can display a map of your network and it can display
a variety of information about each device on the network. It provides version, run-time
status, and URLSs of the applications on the devices and it provides filtering to display only
specified devices. User Tracking provides a tool that tracks IP telephones on a \Voice over
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Syslog Support

Syslog Support
IP (VoIP) network. Path Analysis provides a diagnostic application that traces connectivity

between two specified points on a network and analyzes physical and logical paths.

For more information about CiscoWorks, refer to the documentation available at this URL:http:/
/www.cisco.com/univer cd/cc/td/doc/product/r tr mgmt/cw2000/index.htm

In addition to writing information to a trace file, the Cisco CRS system sends standard event
logging messages to a Syslog server through the Alarm Service. These messages contain
information about the activities of the Cisco CRS Engine and its subsystems. You can use any
Syslog server to analyze these messages.

For analyzing Syslog messages, the Cisco CRS system integrates with CiscoWorks Resource
Management Essentials (RME). The RME Cisco Syslog Analyzer controls and displays all
event messages so that they can easily be read, interpreted, filtered, and used for system
maintenance and troubleshooting. In the Syslog Analyzer, these reports are available under
WorkFlow Report. You can also adapt Syslog output from the Cisco CRS system for use with
other network management systems that have standard Syslog receiving capability.

For information about configuring a Syslog server, see Configuring the Alarm Service (page
33).

For more information about CiscoWorks, refer to the documentation available at this URL:http:/
/www.cisco.com/univer cd/cc/td/doc/product/r tr mgmt/cw2000/index.htm

Remote Serviceability

Many of the serviceability tools can be used by a Cisco Service Engineer (CSE) to assist you
with the management and administration of your Cisco CRS system. These tools allow CSEs
to remotely gather system and debugging information if you require help with troubleshooting
or system diagnostics.

With your permission, CSEs can log on to a Cisco CRS server and obtain a desktop or shell
that allows them to perform any function that could be performed locally.

Tools that assist with remote serviceability include:

» CiscoWorks—Provides remote management capabilities for the Cisco CRS system and Cisco
CRS network. For more information, see CiscoWorks Support (page 12).

» Microsoft Windows 2000 Performance Monitoring—Allows monitoring the performance
counters of the Cisco CRS system from local or from remote systems. For more information,
refer to your Microsoft Windows documentation.

» Microsoft Windows 2000 Terminal Service—Provides remote systems with access to

Windows-based applications through terminal emulation. Windows 2000 Server Terminal
Services are integrated with the Windows 2000 operating system.
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About Serviceability

IPCC Express Call Statistics, Recording, and Monitoring Server Serviceability Support

IPCC Express Call Statistics, Recording, and Monitoring Server Serviceability Support

You can set up a dedicated server for monitoring, recording, and maintaining IPCC Express
statistics. Such a server is called an IPCC Express Call Statistics, Recording, and Monitoring
Server. You can also set up a dedicated server or servers for monitoring. These servers are called
IPCC Express Call Monitoring Servers. The CRS installation process automatically sets up and
configures serviceability on these dedicated servers.

Serviceability enables CiscoWorks support and third-party NMS support for the servers and
includes:

» Cisco Discover Protocol (CDP) support, which enables the Media Convergence Server (MCS)
to be discovered automatically by CiscoWorks.

» CISCO-CDP-MIB support.

» SYSAPPL-MIB support, which provides run-time status, version information, and application
discovery for voice recording and monitoring services.

« Standard third-party MIB support.

» EMBLEM support for CiscoWorks.

Database Expansion Server Serviceability Support

You can install the CRS databases on a dedicated expansion server. The CRS installation process
automatically sets up and configures serviceability on this expansion server.
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Database Expansion Server Serviceability Support

Serviceability enables CiscoWorks support and third-party NMS support for all the CRS nodes
and expansion servers and includes:

Cisco Discover Protocol (CDP) support, which enables the MCS to be discovered
automatically by CiscoWorks.

CISCO-CDP-MIB support.

SYSAPPL-MIB support, which provides run-time status, version information, and application
discovery for SQL services.

Standard third-party MIB support.
EMBLEM support for CiscoWorks.

SYSAPPL-MIB support, which provides run-time status, version information, and application
discovery for SQL services.

Standard third-party MIB support.

EMBLEM support for CiscoWorks

Cisco Customer Response Solutions Servicing and Troubleshooting Guide 4.0(x)

15



About Serviceability

Database Expansion Server Serviceability Support
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Chapter 2

Simple Network Management Protocol Support

Simple Network Management Protocol (SNMP) is an industry-standard interface for exchanging
management information between network devices. SNMP and its components provide you
with information about your Cisco CRS system. You can refer to this information to monitor
and manage the status of the Cisco CRS system, its subsystems, and its related installed
components. You can also use this information to troubleshoot problems, if they arise.

You can set up SNMP traps to automatically notify you of high-severity messages and errors
that are generated by the Cisco CRS system.

This section contains the following topics:

» SNMP Basics, page 18

« SNMP Agent and Subagents, page 18

« SNMP Management Information Base (MIB) , page 18
e SYSAPPL-MIB , page 19

» CISCO-VOICE-APPS-MIB, page 25

« CISCO-CDP-MIB, page 25

* SNMP Traps, page 25

* SNMP Trap Messages, page 25

» Setting up SNMP Traps, page 26

» Setting the SNMP Trap Receiver, page 27

» Setting the SNMP Community Names, page 27

« Starting, Stopping, and Confirming the SNMP Service , page 28
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SNMP Basics

SNMP Basics

A network management system (NMS) uses SNMP to exchange management information
between devices on a network. An SNMP-managed network is made up of the following main
components:

» Managed devices—Network nodes, each containing an SNMP agent. Managed devices collect
and store information and make this information available using SNMP.

» Agents—Network management software that resides on a managed device. An agent contains
local knowledge of management information and translates the information into a form that
is compatible with SNMP.

» Management stations—Computers on which the NMS is installed and from which system
administrators can retrieve and evaluate information from managed devices.

SNIMP Agent and Subagents

The Microsoft Windows SNMP service (referred to as the SNMP Service) provides a framework
for SNMP and provides the SNMP agent that interfaces with SNMP subagents.

SNMP Service starts automatically when the system starts. You can restart or stop the SNMP
Service if a problem occurs or if it did not start automatically.

For more information, see Starting, Stopping, and Confirming the SNMP Service (page 28).

For information on configuring SNMP Service, see SNMP Traps (page 25).

SNIMP Management Information Base (MIB)

A Management Information Base (MIB) designates a collection of information that is organized
hierarchically. You access MIBs with SNMP. MIBs are made up of managed objects, which

are identified by object identifiers. Managed objects are made up of one or more object instances,
which are essentially variables. MIBs provide status monitoring, provisioning and notification.
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SYSAPPL-MIB

The Cisco CRS system supports these MIBs:

» SYSAPPL-MIB—Provides system information, such as installed applications, application
components, product version, processes that are running, and process start time. For more
information, see SYSAPPL-MIB (page 19).

» CISCO-VOICE-APPS-MIB—Contains information about supported SNMP traps. For more
information, see CISCO-VOICE-APPS-MIB (page 25).

» CISCO-CDP-MIB—Provides information about device identifications, CDP (Cisco Discovery
Protocol) running status, CDP transmitting frequency, and the time for the receiving device
to hold CDP messages (time to live). For more information, see "Cisco Discovery Protocol
Support.”

Standard third-party MIBs, including:

— Standard Microsoft MIBs, such as MIB 11

— Compag Insight Agent MIBS for Compaq MCS 78xx platforms

— IBM UM MIB for IBM 3xx MCS platforms
SNMP Community Names authenticate access to MIB objects and serve as passwords for SNMP
information. A system can exchange SNMP information only with systems in the same

community. For more information on setting up communities, see the "Setting the SNMP Trap
Receiver" section.

For additional information about MIBs, refer to this URL: http://www.cisco.com/public/
sw-center/netmgmt/cmtk/mibs.shtml

SYSAPPL-MIB

The SYSAPPL-MIB provides system information about installed packages, including product
name, product version, URL of the Cisco CRS Administration page, run-time status, application
start time, and currently running processes.
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SYSAPPL-MIB
The SYSAPPL-MIB allows you to use CiscoWorks or a third-party NMS browser to remotely
access information about the DC Directory Server and about the Cisco CRS components
including:
 Cisco CRS Administration
» Cisco CRS Node Manager
» Cisco CRS Engine
» Cisco CRS Repository Datastore
 Cisco CRS Historical Datastore
» Cisco CRS Config Datastore
» Cisco CRS Agent Datastore

« Cisco Recording

« Cisco Monitoring

The SYSAPPL-MIB also provides access to the Cisco CRS Services, including:
 Cisco CRS Cluster View Daemon

including but not limited to:

Manager Manager

Log Manager

Config Manager

Executor Manager

Cluster Manager

Node Manager
e Cisco CRS Administration

including but not limited to:

Manager Manager

Log Manager

Config Manager

Executor Manager
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SYSAPPL-MIB
— Cluster Manager
— Node Manager
— File Manager
— Prompt Manager
— Grammar Manager
— Document Manager
— Resource Manager
— Script Manager
— Expression Manager

» Cisco CRS Engine
including but not limited to:
— Manager Manager
— Log Manager
— Config Manager
— Executor Manager
— Cluster Manager
— Node Manager
— File Manager
— Prompt Manager
— Grammar Manager
— Document Manager
— Resource Manager
— Script Manager
— Expression Manager
— RTP Port Manager
— Contact Manager

— Channel Manager
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SYSAPPL-MIB

Session Manager

ICM Subsystem

JTAPI Subsystem

CMT Subsystem

MRCP ASR Subsystem

MRCP TTS Subsystem

eMail Subsystem

RmMCm Subsystem

\oice Browser Subsystem

Core Real-Time Reporting Subsystem
Enterprise Server Data Subsystem
Database Subsystem

VOIP Monitor Subsystem

HTTP Subsystem
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— <Other Custom Subsystem>

Cisco Desktop License and Resource Manager
Cisco Desktop Call and Chat Service

Cisco Desktop Enterprise Service

Cisco Desktop IP Phone Agent Service

Cisco Desktop Recording and Statistics Service
Cisco Desktop VOIP Monitor Service

Cisco Desktop Recording Service

Cisco Desktop LDAP Monitor Service

CRS SQL Server--Repository

CRS SQL Server--Historical

CRS SQL Server--Config

CRS SQL Server--Agent

Microsoft SQL Agent

Microsoft Distributed Transaction Coordinator

SYSAPPL-MIB

The SYSAPPL-MIB also allows you to use CiscoWorks or a third-party NMS to remotely
access information about these IPCC Express Standard and IPCC Express Enhanced packages:

Cisco CRS RAS Server

Cisco CRS TAI Server

Cisco CRS Enterprise Server
Cisco CRS VoIP Monitor Server

Cisco CRS Chat Server

The SYSAPPL-MIB also allows you to use CiscoWorks or a third-party NMS to remotely
access information about these services on an IPCC Express Call Statistics, Recording, and

Monitoring Server, or on an IPCC Express Call Monitoring Server:

Cisco CRS RAS Server

Cisco CRS \WolP Monitor Server
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SYSAPPL-MIB

The SYSAPPL-MIB also allows you to use CiscoWorks or a third-party NMS to remotely

access information about the status of the SQL services MSSQLService and SQLServerAgent.

For a standalone CRS server (a server on which CRS but not Cisco CallManager is installed),

and for a Database Expansion Server, this information appears as "Cisco CRS Database." For

a coresident server (a server on which both Cisco CRS and Cisco CallManager are installed),

this information appears as "Cisco CallManager Database."

If the Cisco CRS Engine is located on the same server as the Cisco CallManager, the

SYSAPPL-MIB allows you to use CiscoWorks or a third-party NMS to remotely access

information about these Cisco CallManager applications and services:

 Cisco CallManager

+ Cisco MOH Audio Translator

» Cisco CallManager Database

 Cisco CDR Insert

 Cisco CTIManager

» DC Directory Server

« Cisco IP \Voice Media Streaming Application

» Cisco Messaging Interface RIS Data Collector

» Cisco TFTP Server

» Cisco Web Attendant Server

The SYSAPPL-MIB uses SNMP to organize and distribute the information that it gathers from

your network. The Cisco CRS system supports these SYSAPPL-MIB tables:

» SysApplinstallPkgTable—Provides installed application information, including manufacturer,
product name, product version, date installed, and location, which is a partial URL for
accessing the associated Cisco CRS Administration web page (when applicable)

» SysApplRunTable—Describes the application starting time and run-time status

» SysApplinstallEImtTable—Describes the individual application elements or the associated
executables that make up the applications defined in the SysApplinstallPkgTable

» SysApplEImtRunTable—Describes the processes that are currently running on the host
system, similar to the processes that the Windows Task Manager displays

For more information about the SYSAPPL-MIB, refer to this URL: ftp://ftp.cisco.com/pub/
mibs/v2/SY SAPPL-MIB.my
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CISCO-VOICE-APPS-MIB

CISCO-VOICE-APPS-MIB

The CISCO-VOICE-APPS-MIB provides information about supported SNMP traps. For more
information about the CISCO-VOICE-APPS-MIB, refer to this URL: ftp://ftp.cisco.com/pub/
mibs/v2/CISCO-VOICE-APPS-MIB.my

CISCO-CDP-MIB
The CISCO-CDP-MIB provides information about device identifications, CDP running status,
CDP transmitting frequency, and the time for the receiving device to hold CDP messages (time
to live). This MIB stores information in a table called cdpGlobalinfo.
For more information about the CISCO-CDP-MIB, refer to this URL: ftp://ftp.cisco.com/pub/
mibsiv2/CISCO-CDP-MIB.my

SNIMP Traps
You can set up SNMP traps to automatically notify you of high-severity messages and errors
that come from the Cisco CRS Engine. An SNMP agent can send traps that identify these
important system events. Traps can also come from the Alarm Service. The Alarm Service
forwards messages to the SNMP trap subagent, which sends the messages to the SNMP trap
receiver in the proper format.
SeeAlso
SNMP Trap Messages on page 25
Setting up SNMP Traps on page 26
Cisco AVVID Alarm Service on page 31
Viewing Alarm Messages on page 34

SNMP Trap Messages

The following table shows the Cisco CRS SNMP trap messages that are sent to an NMS specified
as a trap receiver. These trap messages can be sent for each subsystem shown in the
"SYSAPPL-MIB" section.

Table 3: SNMP Trap Messages
Message Description

cvaProcessStart A Windows process associated with the Cisco CRS server started.
The processld parameter specifies the Windows process ID.
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Setting up SNVIP Traps

Message Description

cvaProcessStop A Windows process associated with the Cisco CRS server
stopped or aborted. The processld parameter specifies the
Windows process ID.

cvaModuleStart A subsystem started successfully and became in-service. The
trap includes the severity level and the module name.

cvaModuleStop A subsystem stopped. The trap includes the severity level and
the module name. The cvaModuleFailureCause parameter
specifies the cause, if available.

cvaModuleRunTimeFailure |A run-time failure occurred. The trap includes the severity level
and module name. The cvaModuleRunTimeFailureCause
parameter specifies the cause, if available.

When an SNMP agent detects an alarm condition, it generates a trap (also called a notification)
that is sent to configured IP addresses. To set up SNMP traps, see the "Setting up SNMP Traps"
section.

Setting up SNMP Traps

To use SNMP traps, you must designate the SNMP trap destination for the trap messages.

You can specify the following security options for the SNMP traps to ensure that only authorized
systems have access to SNMP trap information:

» Community strings—Serve as passwords for SNMP information. A system can exchange
SNMP information only with systems in the same community.

» Valid sources for SNMP requests.

» Read/write privileges—Whether systems can only read SNMP information or can read and
write information.

For additional information about SNMP security, refer to your Microsoft Windows

documentation.

To configure the SNMP trap sender, see these sections:

» Setting the SNMP Trap Receiver (page 27)

» Setting the SNMP Community Names (page 27)
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Setting the SNMP Trap Receiver

Setting the SNMP Trap Receiver

Step 1
Step 2

Step 3

Step 4
Step 5

Step 6

Step 7
Step 8

Step 9

Step 10
Step 11

Step 12

The trap receiver is the network management system (NMS) that receives the SNMP traps. This
NMS must have the same SNMP community string as the trap sender. The Cisco CRS system
sends traps that can be received by CiscoWorks and by standard third-party NMSs.

To set the SNMP trap receiver, follow these steps:

From the Windows desktop, choose Start > Settings > Control Panel.
Double-click Administrative Tools.

Double-click Services.

The Services window appears.

Right-click SNM P Services and choose Properties.

Click the Trapstab.

In the Community name field, enter the community name to which this computer will send trap
messages.

You must configure at least one community string or SNMP will not respond to requests.
Community name is case-sensitive

Click Add to List.
Under the Trap destinations field, click Add.

In the SNMP Service Configuration dialog box, enter the IP address or the host name of the
trap destination.

In the SNMP Service Configuration dialog box, click Add.
Repeat Step 7 through Step 10 for each trap destination required.

Click OK to apply your changes and exit the SNMP Service Properties window.

Setting the SNMP Community Names

You can configure security settings for the SNMP traps to ensure that only authorized system
can access information that is sent to the traps. SNMP community names serve as passwords
for SNMP information. You can set valid sources for SNMP requests and specify whether
systems can only read information, or both read and write information. For more information
about SNMP security, refer to your Microsoft Windows documentation.
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Starting, Stopping, and Confirming the SNMP Service

Step 1
Step 2

Step 3

Step 4
Step 5

Step 6

Step 7

Step 8

Step 9
Step 10

Step 11

Step 12

To set up community names and privileges, follow these steps:

From the Windows desktop, choose Start > Settings > Control Panel.
Double-click Administrative Tools.

Double-click Services

The Services window appears.

Right-click SNM P Services and choose Properties.

Click the Security tab.

In the Accepted Community Names pane, click Add.

The SNMP Service Configuration dialog box appears.

In the Community Name field, enter the name of the community.

If you need write privileges for the community, choose READ WRITE from the Community
Rights drop-down list.

On the SNMP Service Configuration dialog box, click Add.
Repeat Step 6 through Step 9 as needed to add other community names.

If you want to allow only specific NMS hosts to query the SNMP subagent, follow these steps:

o

Click the Accept SNM P packets from these hosts radio button.
b.  Inthe Accept SNMP packets from these hosts pane, click Add.

c. Inthe SNMP Service Configuration dialog box, enter the IP address or the host name of
the host that is allowed to query the SNMP subagent.

d.  Inthe SNMP Service Configuration dialog box, click Add.

®

Repeat Steps a through d as needed.

Click OK to apply your changes and exit the SNMP Service Properties window.

Starting, Stopping, and Confirming the SNMP Service

Step 1

In general, the SNMP Service will always be running. To confirm that the SNMP Service is
running and to restart it or stop it, if necessary, follow these steps:

From the Windows desktop, choose Start > Settings > Control Panel
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Starting, Stopping, and Confirming the SNMP Service

Step 2 Double-click Administrative Tools.
Step 3 Double-click Services.
The Services window appears.

Step 4 Look at the Status field in the SNMP Service row.

If this field displays "Started," the SNMP Service is running. If this field is blank, the SNMP
Service is not running.

To start the SNMP Service, right-click SNM P Service and choose Start.

To stop the SNM P Service, right-click SNMP Service and choose Stop.
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Starting, Stopping, and Confirming the SNMP Service
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Chapter 3

Alarm Service

Alarms provide information about the Cisco CRS system activities. You can use this information
to monitor the status and the state of the system and to determine actions to take if a problem
occurs. By default, the Cisco CRS system also writes alarm information to trace files. You can
use the information in a trace file for further analysis of a problem.

This section contains the following topics:

» Cisco AVVID Alarm Service, page 31

« Starting and Confirming the Alarm Service, page 33

« Configuring the Alarm Service, page 33

« Viewing Alarm Messages, page 34

« Viewing Alarm Messages Sent to a Syslog Server, page 34

« Viewing Alarm Messages Sent to an SNMP Trap Receiver, page 36
« Viewing Alarm Messages Sent to a Windows Event Log, page 36

« Alarm Definitions, page 37

» Finding Information About an Alarm, page 37

Cisco AWID Alarm Service

The Cisco AVVID Alarm Service is installed as part of the Cisco CRS installation process. It
is a Windows service that receives alarms about system events from the Cisco CRS Engine,
Cisco CRS Node Manager, Cisco CRS Administration, Cisco CRS Repository Datastore, Cisco
CRS Historical Datastore, Cisco CRS Config Datastore, Cisco CRS Agent Datastore, Cisco
Recording, and Cisco Monitoring components. These alarms are defined in XML format in files
called catalogs. Catalogs are set up as part of the Cisco CRS installation process.
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Cisco AVVID Alarm Service

Based on catalogs, the Cisco AVVID Alarm Service forwards the alarms that it receives to one
or more of the following destinations:

» Syslog Server—Forwards alarms as standard Syslog-format messages to CiscoWorks or any
third-party Syslog server. For related information, see CiscoWorks Support (page 12).

» SNMP Trap Subagent—Processes alarms and sends them as traps to a configured trap receiver,
such as the Voice Health Monitor (VHM) in CiscoWorks. For more information, see
CiscoWorks Support (page 12) and SNMP Traps (page 25).

» Windows Event Log—Sends alarms that can be viewed with the Windows Event Viewer.
For more information, see Viewing Alarm Messages Sent to a Windows Event Log (page
36).

You can specify the severity level of the alarm that the Cisco AVVID Alarm Service sends to
a Syslog server. Alarm severity levels are described in the following table. For more information,
see Configuring the Alarm Service (page 33).

Table 4: Alarm Severity Levels

Severity |Name Explanation

Level

0 EMERGENCY_ALARM System emergency

1 ALERT_ALARM Situation where the application will continue to

run but not all functions are available

2 CRITICAL_ALARM Critical failure that prevents the application from
accomplishing a task

3 ERROR_ALARM Critical failure that prevents the application from
accomplishing a task

4 WARNING_ALARM Problem exists but it does not prevent the
application from completing its tasks

5 NOTICE_ALARM Notification of a normal but significant condition

6 INFORMATIONAL_ALARM |Information that does not relate to errors,
warnings, audits, or debugging

7 DEBUG_ALARM Detailed information regarding system errors and
processing status

SeeAlsD

CiscoWorks Support on page 12
SNMP Traps on page 25
Setting Trace Level Options on page 48
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Starting and Confirming the Alarm Service

Starting and Confirming the Alarm Service

Step 1
Step 2

Step 3

Step 4

In general, the Cisco AVVID Alarm Service is always running.

To confirm that the Alarm Service is running and to restart it, if necessary, follow these steps:

From the Windows desktop, choose Start > Settings > Control Panel.

Double-click Administrative Tools.

Double-click Services.

The Services window appears.

Look at the Status field in the Cisco AVVID Alarm Service row.

If this field displays “Started”, the Alarm Service is running. If this field is blank, start the Alarm

Service by right-clicking Cisco AVVID Alarm Service in the Name field, and then choosing
Start.

SeeAlD

Configuring the Alarm Service on page 33

Configuring the Alarm Service

Step 1

Step 2

When you configure the Alarm Service, you provide the Cisco CRS system with information
about how to handle alarms. To configure the Alarm Service, perform the following steps.

If you will be entering information in the Syslog Server Name field or in the Syslog Message

Filtering Level field, as explained in Step 3, make sure that the Alarm Service is running before
following these steps. (See the “Starting and Confirming the Alarm Service” section for more

information.)

From the Cisco CRS Administration menu, choose System > Alarm Configur ation.
The Alarm and Tracing Configuration page appears.

Choose Alarm Server Tracing from the navigation bar.
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Viewing Alarm Messages

Step 3 Enter information in the fields under Alarm Service as follows:

« Alarm Server—IP address or name of the server on which the Cisco AVVID Alarm Service
is running. By default, the Alarm Server is “localhost,” meaning that the Alarm Service is
running on the Cisco CRS server. You cannot change this information.

« Alarm Server Port—Port on the Alarm Server to which alarm messages are sent. This
information is entered as part of the installation process. The default value is 1444. You
cannot change this information.

 Catalog Directory—Directory in which the catalogs of alarm messages are stored. The default
is “catalog”. This information is entered as part of the installation process. You cannot change
this information.

» Syslog Server Name—Enter the IP address or the host name of the Syslog server to which
alarm messages are be sent. If you are using CiscoWorks, enter the IP address or the host
name of the CiscoWorks server. If this field is blank, the system sends alarm messages to
the Cisco CRS server.

» Syslog Message Filtering Level—Click the drop-down arrow and choose the severity level
of alarm messages that you want sent to the Syslog server. Syslog messages range from
severity 0 (most severe) to severity 7 (least severe). When you choose a severity level, all
messages of that severity level and higher will be sent. For example, if you choose
ERROR_ALARM (Severity 3), all messages of severity 3, severity 2, severity 1, and severity
0 will be sent. The default is “DEBUG_ALARM (Severity 7)”, which will send messages
of all severity levels.

Step 4 Click Update.

Viewing Alarm Messages

The way in which you view alarm messages depends on the destination to which messages were
sent. Each alarm message that you view will include an alarm name. To find information about
the alarm name that appears in an alarm message, see Alarm Definitions (page 37).

SeeAlD

Viewing Alarm Messages Sent to a Syslog Server on page 34
Viewing Alarm Messages Sent to an SNMP Trap Receiver on page 36
Viewing Alarm Messages Sent to a Windows Event Log on page 36
Alarm Definitions on page 37

Viewing Alarm Messages Sent to a Syslog Server

To view alarm messages that were sent to a CiscoWorks Resource Management Essentials
(RME) Syslog server, refer to the CiscoWorks documentation, available at this URL: http://
www.cisco.com/univer cd/cc/td/doc/product/r tr mgmt/cw2000/index.htm
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Viewing Alarm Messages Sent to a Syslog Server

To view alarm messages that were sent to a third-party Syslog server, refer to the documentation

for that system.

The following table describes the fields found in Syslog messages:

Table 5: Syslog Message Format

Field Example Description

<pri> <128> This field is added so that syslog can read the
severity level. Syslogd looks for this pri value
which is set to LOCALO|SEVERITY by default.

n: 100: This field mimics the Solaris syslogd, which
prefixes the syslog message with an internal
counter szi. It has no significance to the SAC. The
number is parsed out by the SAC.

MMM DD Aug 09 Abbreviated month day as known at the source.

hh:mm:ss.mmm  |19:20:10.209 Time at source device. The UTC time is used to
avoid any time zone name discrepancy.

TimeZone uTC Abbreviated time zone defined in the device, such
as GMT. This field is always set to UTC to avoid
any time zone name discrepancy.

% FACILITY CDP (Cisco A code consisting of two or more uppercase letters

Allowed characters
A-Z0-9

Discovery Protocol),
ALIGN (Memory
optimization in

that indicate the facility to which the message
refers. A facility can be a hardware device, a
protocol, or a module of the system software. Note

RISCh that this is not the same as the UNIX Syslog server
logging facility.
[SUBFACILITY-] |CLAW (Common Subfacility Code. This field is optional.

A-Z09 _

Link Access for
Workstations)

SEVERITY 0 A single-digit code from 0 to 7 that reflects the
severity of the condition. The lower the number,
the more serious the situation. Severity also maps
to logging level.

MNEMONIC BADIPALIGN: The mnemonic code uniquely identifies the error

Invalid alignment in
packet for IP.

message. This code is used by CiscoWorks 2000
to associate the syslog message with the message
information in the message catalog.

1)  Reduced Instruction Set Computer
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Viewing Alarm Messages Sent to an SNMP Trap Receiver

Field Example Description

Message-text Module Failure A text string describing the condition.
Cause=Unknown

Sample For mat:

<LOCAL7|SEVERITY>51:0ct 18 03:28:29.327 PDT: %MIVR-GENERIC-1-ModuleStop:
Module has stopped; Module Name=HTTP SubSystem; Module Failure
Cause=Unknown

SeeAlD

Alarm Definitions on page 37

Viewing Alarm Messages Sent to an SNMP Trap Receiver

To view alarm messages that were sent to the CiscoWorks Voice Health Monitor (VHM), refer
to the CiscoWorks documentation, available at this URL: http://www.cisco.com/univer cd/cc/
td/doc/product/rtr mgmt/cw2000/index.htm

To view alarm messages that were sent to a third-party SNMP trap receiver, refer to the
documentation for that system.

SeeAlso

SNMP Traps on page 25
Alarm Definitions on page 37

Viewing Alarm Messages Sent to a Windows Event Log

Step 1
Step 2
Step 3

Step 4

You use the Windows Event Viewer to view alarm messages that were sent to a Windows event
log. To use the Windows Event Viewer, perform the following steps. For additional information
about the Windows Event Viewer, refer to your Microsoft Windows documentation.

From the Windows desktop, choose Start > Setting > Control Panel.
Double-click Administrative Tools.
Double-click Event Viewer.

On the Tree pane, click the item for which you want to view information.

SeeAlD

Alarm Definitions on page 37
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Alarm Definitions

Alarm Definitions

Cisco CRS maintains a list of alarm catalogs. Each of these catalogs contains a list of alarms.
Each alarm contains a definition of the alarm, which includes the alarm name, a description, an
explanation, recommended actions, and related information.

An alarm name appears in an alarm message as follows:
» Trace file—Alarm name follows the severity level.

» CiscoWorks RME—Alarm name appears in the Mnemonic field on the Syslog WorkFlow
report.

 Third-party Syslog server—Alarm name follows the reason. If a reason is not shown the
alarm message name follows the module name.

» Windows Event Viewer—Alarm name follows the severity level.

Finding Information About an Alarm

Step 1

Step 2

Step 3

To use the alarm catalog to find information about an alarm message name, follow these steps:

From the Cisco CRS Administration menu, choose Tools > Alar m Definition.
The Alarm Definitions web page appears.
Locate information for the alarm message name as follows:

« For alist of all alarm message names, make sure that All appears in the Catalog field, and
then click Search.

« For alist of alarm message names that relate to a specific facility and subfacility, click the
Catalog drop-down arrow, choose the desired item, and then click Sear ch.

 For a specific alarm message name, type the name of the alarm in the Enter Alarm Name
field, and then click Search.

A list of the alarm message names that you requested appears. If the list contains more than one
page, you can click First, Previous, Next, or Last to move through the list. You can also type
a page number in the Page field and click Page to move to that page.

To see a detailed explanation of an alarm message name, click the alarm message name.

Cisco Customer Response Solutions Servicing and Troubleshooting Guide 4.0(x)

37



Alarm Service

Finding Information About an Alarm

Cisco Customer Response Solutions Servicing and Troubleshooting Guide 4.0(x)

38




Chapter 4

Trace

A trace file is a log file that records activity from the Cisco CRS components. Trace files let
you obtain specific, detailed information about the system that can help you troubleshoot
problems.

The Cisco CRS system can generate trace information for every component subfacility. This
information is stored in a trace file. To help you control the size of an trace file, you specify the
component and subfacilities for which you want to collect information and the level of
information that you want to collect.

The Cisco CRS system also generates information about all threads that are running on the
system. This information is stored in the thread dump trace file and is useful for troubleshooting.

This section contains the following topics:

« The Component Trace File, page 40

« Configuring the Component Trace File, page 40

« Trace Level Options, page 41

» Setting Trace Level Options, page 48

« Viewing and Interpreting the Trace Files , page 49
» Displaying a Trace File, page 49

« Interpreting a Trace File , page 50

e The Thread Dump Trace File, page 50

» Writing to the Thread Dump Trace file, page 50

« Displaying the Thread Dump Trace File , page 51
» The CRS Log Files, page 51
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The Component Trace File

The Component Trace File

You can create a trace file for any of the following Cisco CRS components:

» Cisco CRS Engine

 Cisco CRS Administration

 Cisco CRS Editor

» Cisco CRS Node Manager

» Cisco CRS SQL Server

The component trace file contains information about each of the component's subfacilities. To
set up this trace file, you perform the following general procedures:

» Configuring the Component Trace File (page 40)

» Setting Trace Level Options (page 41)

For information about reading the trace file, see the Viewing and Interpreting the Trace Files
(page 49)

Configuring the Component Trace File

Step 1

Step 2

By default, the Cisco CRS system sends information about subfacilities to a trace file, for
example, CiscoMIVRnn.log. The system replaces nn with a number, starting with 01. You can
configure the size of the trace file. When the size you configured is reached, or if a Cisco CRS
component is restarted, the system creates a new trace file, incrementing nn by one. After
creating the tenth trace file (by default), the trace file begins overwriting existing files, starting
with the first trace file created.

Note that the examples shown here are for the Cisco CRS Engine component. Follow the same
procedures for the other components, substituting the component's name.

To change any of these default trace file parameters, follow these steps:

From the Cisco CRS Administration menu, choose System > Tracing.
The Trace Configuration page appears.

Choose and expand a component from the navigation bar.
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Trace Level Options

Step 3 Change the following information under Trace File as needed:

» Trace File Output—Check this check box to send information to a trace file. Uncheck this
box if you do not want to send information to a trace file. By default, this check box is
checked.

» File Name—Enter the base name and the extension of the trace file. A trace file name is made
up of the base facility name, the file number, and the extension (for example,
CiscoMIVRO1.log). The default file name is Cisco<facility code>.log.

Where the <facility_code could be MIVR, MCVYD, MADM, MEDT, or MARC.

« Number of Trace Files—Enter the number of trace files that the system will create before
starting to overwrite existing files. The system will create a new trace file each time the
existing one reaches the size specified in the Trace File Size field. The default number of
trace files is 10.

» Trace File Size—You can configure the file size, or you can enter the maximum size, in
bytes, of the trace file. The default files size is 1048576.

Step 4 Click Update.

Trace Level Options

A trace file is a log file that records activity from the Cisco CRS component subsystems and
steps. Trace files let you obtain specific, detailed information about the system that can help
you troubleshoot problems.

The Cisco CRS system can generate trace information for every subfacility. This information
is stored in an engine trace file. To help you control the size of an engine trace file, you specify
the subfacilities for which you want to collect information and the level of information that you
want to collect.

The Cisco CRS system also generates information about all threads that are running on the
system. This information is stored in the thread dump trace file and is useful for troubleshooting.

A trace file that records all information for a component, such as the Cisco CRS Engine, can
become large and difficult to read. To help you manage the trace file, the Cisco CRS system
lets you specify the subfacilities for which you want to record information. These subfacilities
are shown in the following table.

For each subfacility, you can select a trace level of Debugging, Alarm Tracing, both selections,
or no selections. These selections specify the messages that the system sends to a trace file. The
following table shows the effect of each trace level settings. For an explanation of message
severity levels, see Cisco AVVID Alarm Service (page 31).
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Table 6: Messages Sent to a Trace File

Selection Severity Level of Explanation
Messages Sent
Debugging 0,1,23,7 Sends detailed, verbose information. To be
used primarily for debugging and
troubleshooting.
Alarm Tracing 0,1,2,3,4,56 Sends messages of all severity levels except

detailed debugging information.

Tracing

Debugging and Alarm (0,1, 2,3,4,5,6,7

Sends messages of all severity levels.

No selections

0,123

Sends high-priority notifications, errors, and
alerts.

The Trace Configuration pane groups trace level options into these lists:

» Active trace level options—Facilities and subfacilities that are running on your system

* Inactive trace level options—Facilities and subfacilities that are not running on your system

If you make a change under an active facility, the trace file will reflect your change immediately.
If you make a change under an inactive subfacility, the change will take effect when the
subfacility becomes active.

Warning: Level 7 traces are debug only and do not reflect a system issue.

All applications that use the CRS Trace library use a Syslog Facility Code. The following table
lists the Facilities and Descriptions for the Trace Files.

Table 7: Trace File Facilities

Facility Code

Description

MIVR

Workflow Application Framework

MCVD

Cluster Framework

MADM

CRS Administration page

MEDT

Editor

MARC

Archive Framework

The following table describes the Trace file subfacilities:
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Table 8: Trace File Subfacilities

Trace Level Options

Subfacility Code

Description

AC_CLUSTER Archive Cluster Component
AC_CONFIG Archive Configuration Component for CRS 4.0
AC_CONFIG3x Archive Configuration Component for CRS 3x.

AC_DATABASE

Archive Database Component for CRS 4.0

AC_DATABASE3x

Archive Database Component for CRS 3.x

AC_JTAPI JTAPI Archive Component

AC_LDAP LDAP Archive Component for CRS 4.0
AC_LDAP3x LDAP Archive Component for CRS 3x

AC _0S Archive Operating System Component

AC_SPANLINK CAD/CSD Archive Component

AC_SPANLINK3x

CAD/CSD Archive Component for CRS 3.x

AC_SPANLINKA40

CAD/CSD Archive Component for CRS 4.0

ADM Administration Client

ADM_CFG Administration Configuration
APP_MGR Applications Manager

ARC Archive Tool

ARCHIVE_MGR Archive Manager

ARCR Archive for Restore

AW_CFG Restore Administration Configuration
CFG_MGR Configuration Manager

CHANNEL_MGR

Channel Manager

CLUSTER_MGR

Cluster Manager
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Subfacility Code

Description

CONTACT_MGR

Contact Manager

CONTACT_STEPS

Contact Steps

CRA_CMM CRS ClusterMsgMgr Component
CRA_HRDM CRS Historical Reporting Data Manager
CvD Cluster View Daemon

DB Database

DBPURGE_MGR

Database Purge Manager

DESKTOP CRS Editor Desktop
DOC_MGR Document Manager
EDT CRS Editor general

ENG CRS Engine

EXECUTOR_MGR

Executor Manager

EXPR_MGR Expression Manager
FILE_MGR File Manager
GENERIC Generic catalog for a facility

GRAMMAR_MGR

Grammar Manager

GRP_CFG

Group Configuration

HOLIDAY_MGR

Holiday Manager

HR_MGR

Historical Reports Manager

ICD_CTI

IPCC Express CTI? Server

2)  CTI = Computer Telephony Interface
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3)
4
5)

6)

Trace Level Options

Subfacility Code

Description

|ICD_HDM Ipcc® Express Historical Data Manager
ICD_RTDM IPCC Express Real-Time Data Manager
I0_ICM

Icm? Input/Output

LIB_APPADMININTERCEPTOR

CRS Administration Interceptor Library

LIB_AXL AXL Library
LIB_CFG Configuration Library
LIB_CRTP CRTP Library

LIB_DATABASE

Database Library

LIB_DIRECTORY

Directory Access Library

IPCC = Internet Protocol Contact Center
ICM = Intelligent Contact Management
JDBC = Java Database Connectivity

LDAP = Lightweight Directory Access Protocol

LIB_ EVENT Event Message Library

LIB_ICM ICM Library

LIB_JASPER Jasper Tomcat Library

LIB_JCUP JavaCup Library to parse expressions
LIB_JDBC JDBC® Library

LIB_JMAIL Java Mail Library

LIB_LDAP LDAP® Library

LIB_JLEX JLEX Library used to parse expressions
LIB_LICENSE License Library

LIB_MEDIA Media Library
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Subfacility Code

Description

LIB_RMI Java Remote Method Invocation Library
LIB_SERVLET Servlet Library
LIB_TC Tomcat Library
LOG_MGR Log Manager
MRCP_CFG MRCP’ Configuration
MGR_MGR Manager Manager
NODE_MGR Node Manager
PALETTE Editor Palette
PROMPT_MGR Prompt Manager
PURGING Purging

RPT Reporting

RTPPORT_MGR

RTP® Manager

SCRIPT_MGR Script Manager

SESSION_MGR Session Manager

SS_APP Application Subsystem

SS_ CM Contact Manager Subsystem

SS CMT Cisco Media Termination Subsystem
SS DB Database Subsystem

SS _ EMAIL E-mail Subsystem

SS ENT_SRV Enterprise Server Subsystem

7)  MRCP = Media Resource Control Protocol

8)  RTP = Real-Time Transport Protocol
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Subfacility Code Description

SS_HTTP HTTP Subsystem

SS ICM ICM Subsystem

SS MRC MRC Subsystem

SS_MRCP MRCP Subsystem
SS_MRCP_ASR MRCP ASR? Subsystem
SS_MRCP_TTS MRCP TTS Subsystem

SS_ RM Resource Manager Subsystem
SS_RMCM Resource Manager Contact Manager Subsystem
SS_RTR Real-Time Reporting Subsystem
SS_TEL JTAPIH Subsystem (Telephony)
SS VB Voice Browser Subsystem

SS VOIPMON_SRV \oice over IP Monitor Server Subsystem
STEP_CALL_CONTROL Call Control Steps
STEP_ENT_SRV Enterprise Server Steps
STEP_MEDIA_CONTROL Media Control Steps
STEP_SESSION Sessions Steps
STEP_SESSION_MGMT Session Management Steps
STEP_USER User Steps
STEP_CALL_CONTACT Call Contact Steps
STEPS_CONTACT Contact Steps

9)  ASR = Automatic Speech Recognition
10) TTS = Text-to-Speech

11) JTAPI = Java Telephony Application Programming Interface
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Subfacility Code

Description

STEPS_DB

Database Steps

STEPS_DOCUMENT

Document Steps

STEPS_EMAIL

E-mail Steps

STEPS_GENERAL

General Steps

STEPS_GRAMMAR

Grammar Steps

STEPS_HTTP

HTTP Steps

STEPS_ICM

ICM Steps

STEPS_IPCC_EXP

IPCC Express Steps

STEPS_JAVA

Java Steps

STEPS_PROMPT

Prompt Steps

STEPS_SESSION

Session Steps

STEPS_USER.ALARM

User Alarm Steps

TEL Telephony
USR_MGR User Manager
WEB_STEPS HTTP Contact Steps

Note: When the IPCC Express product is running on a 7845 machine and tracing is ON (the
default), limit the Busy Hour Call Completions (BHCC) to 4500 calls per hour. If you want to
run a higher BHCC, turn the debug traces OFF. The trace subfacilities to be turned OFF are
ICD_CTI, SS_TEL, SS_RM, SS_CM, and SS_RMCM.

Setting Trace Level Options

Step 1
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From the Cisco CRS Administration menu, choose System > Tracing.

The Trace Configuration web page appears.
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Viewing and Interpreting the Trace Files

Step 2 Under a specific CRS Component, choose Trace File Configuration from the navigation bar.

Step 3 Check or uncheck the desired boxes in the Active trace level option list and in the Inactive trace
level option list.

Step 4 Click Update.

Step 5 If you made any changes in the Inactive trace level option list, stop and restart the Cisco CRS
Engine to reflect your changes in the trace file.

Viewing and Interpreting the Trace Files

The Cisco CRS server stores the trace files in the Log directory under the directory in which
you installed the Cisco CRS component. From the Cisco CRS Administration menu, you can
view a list of all trace files and display the contents of any trace file.

Displaying a Trace File

To display a CRS component trace file, follow these steps:

Step 1 From the Cisco CRS Administration menu, choose System > Tracing.
The Trace Configuration web page appears.

Step 2 Select and expand a component from the navigation bar and select Trace Configuration.
A list of subfacility categories appears.

Step 3 Expand the category of subfacility, select the levels of debugging for specific subfacilities, and
click Update.

The trace file appears in a separate window.
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Interpreting a Trace File

Interpreting a Trace File

The trace files contain information in standard Syslog format. The file includes some or all of
the following information for each event that it records:

+ Line number

 Date and time the event occurred
« Facility and subfacility name
 Severity level

» Message name

» Explanation

» Parameters and values

The Thread Dump Trace File

The thread dump trace file is named JVM.log. It is stored on the Cisco CRS server in the Log
directory under the directory in which you installed the Cisco CRS Engine. This file contains
stack trace information about all threads that are running on the Cisco CRS system. You can
write information to this file when you need it. In addition, the system writes information to
this file automatically if the system detects a severe system problem. When new information is
generated, it is appended to the existing thread dump file.

SeeAlsD

Writing to the Thread Dump Trace file on page 50
Displaying the Thread Dump Trace File on page 51

Writing to the Thread Dump Trace file

Step 1

Step 2

To manually write to the thread dump trace file, follow these steps:

From the Cisco CRS Administration menu, choose System > Control Center.
The Control Center web page appears.

Click Serversand choose the server hostname from the navigation bar (if it is not the selected
server).
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Step 3

Step 4

Displaying the Thread Dump Trace File

Click Server Traces (at the top), and choose the component for which you want to enable the
thread dump.

Click Dump Threads Trace.

SeeAlso
Displaying the Thread Dump Trace File on page 51

Displaying the Thread Dump Trace File

Step 1

Step 2
Step 3

Step 4

Step 5

The CRS Log Files

To display the thread dump trace file, follow these steps:

From the Cisco CRS Administration menu, choose System > Control Center.
The Control Center web page appears.

Click Serversand choose the server hostname from the navigation bar (if it is not the selected
server).

Click Server Traces(at the top), and choose the component for which you want to enable the
thread dump.

Click Dump Threads Trace.
In the File Name column, click JVM .log.

The trace file appears in a separate window.

The CRS log files can help you troubleshoot problems. The following table provides information
about the log files for the various CRS components and points you to the log file path locations.

Component Path File/Extension
MSI Installer \ (root) CRSMsilnstallLog.txt
Callinstall.log

CRSMsdelnstallLog.txt

Node Manager

\Program Files\wfavvid\log\EMS\ *.ems

Cluster View Daemon (CVD) |\Program Files\wfavvid\log\MCVD\ *.log
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2. SNMP SYSApp

3. SNMP CDP

\Program Files\Cisco\bin\

\Program Files\Cisco\bin\

Component Path File/Extension
Database \Program Files\wfavvid\log\ReplLogs\ *.log
ADS / HDS / RDS \Program Files\Microsoft SQL *.log
CRS SQL Server Logs Server\MSSQL$CRSSQL\LOG\ * log
CRS Administration \Program Files\wfavvid\log\MADM\ *.log
Engine, driverManager \Program Files\wfavvid\log\MIVR\ *.log
JTAPI \Program Files\wfavvid\log\JTAPI\ *.log
CRS Editor \Program Files\wfavvid\log\MEDT\ *.log
Archive Tool \% TEMP%\ log\MARC\ *.log
Serviceability components:  [\Program Files\Cisco\AlarmService\AlarmServiceLog\ |*. log
1. Alarm Service \Program Files\Cisco\AlarmService\Log\ALARM\ *.log

SnmpSysApplimpl.log

SnmpCdplmpl.log

Cisco Desktop Product Suite:
Installation logs

Agent and Supervisor logs

See "Cisco Desktop Product Suite Installation Logs".

\Program Files\Cisco\Desktop\log\

*. log *.dbg

Cisco Desktop Product Suite Installation Logs

If you need to locate the Cisco Desktop Product Suite, Version 6.1, log files, this section helps
you to locate them.

Here are the locations of the various log files:

» The Install Manager log files are located at the root of the C: drive:

The files are:

— « IM<number>.dbg - where <number> ranges between 0001 & 0010, (i.e IM0001.dbg)

— « IM<number>.log

e The InstallShield silent install file is located at C:\Winnt:
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* splk_<project>.log - where <project> is a Desktop installation project, such as splk_base.log.

» The InstallShield install / uninstall debug files are located at <Program
Files>\Cisco\Desktop\IM:

The files are:

— e splkinstall_<version>.dbg - where <version> is a Desktop software version, such as
splkinstall_6.1.0.20.dbg

— e splkinstall_Obj_<version>.dbg - where <version> is a Desktop software version, such
as splkinstall_Obj_6.1.0.20.dbg.
After you uninstall the Desktop, the log files are located at:

1. Install Manager files exist in the location defined above until the uninstall reboot when
they are removed from the system.

2. InstallShield silent uninstall file is at the root of the BootUp drive.

3. InstallShield install / uninstall debug files are at the root of the C: drive.

SeeAlso
Writing to the Thread Dump Trace file on page 50
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Chapter 5

Cisco Discovery Protocol Support

The Cisco CRS system uses the Cisco Discovery Protocol (CDP) to periodically send out CDP
messages to a designated multicast address. These messages contain information such as device
identification, interface name, system capabilities, SNMP agent address, and time-to-live. Any
Cisco device with CDP support can locate a Cisco CRS server by monitoring these periodic
messages.

Using information provided through CDP, the CiscoWorks server discovers your Cisco CRS
server and the Campus Manager application Topology Services builds topology maps that
display the CRS server and other Cisco devices.

CDP is enabled on the Cisco CRS system by default. You must have the CDP driver enabled
at all times for CiscoWorks to discover the CRS server.

Note: The Windows 2000 CDP Protocol Driver is designed to run with Cisco CRS on a Cisco
Media Convergence Server (MCS) with a 10/100BaseT Ethernet network interface card under
Windows 2000 Server. It does not support other media, such as Token Ring, ATM, or Windows
NT platforms (including Windows 98 or Windows NT 4.0).

This section contains the following topics:

» Using the CDP Driver, page 55

» Accessing CDP Driver Control , page 56

« Installing the CDP Protocol Driver, page 56

« Starting the CDP Protocol Driver, page 56

» Enabling the CDP Protocol Driver, page 57

» Showing the CDP Protocol Driver Properties, page 58

« Updating an IP Address for the CDP Protocol Driver, page 58
» Locating Updated CDP Driver and Interface Files , page 59

» Default CDP Settings , page 59

Using the CDP Driver

Starting a system on which Cisco CRS is installed enables the CDP driver. You can use CDP
to allow CiscoWorks to discover and manage your Cisco CRS systems.
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Accessing CDP Driver Control

CiscoWorks uses the CDP cache MIB of the direct neighboring device to discover the Cisco
CRS server. You can use CiscoWorks to query other Cisco CRS-supported MIBs for provisions
or statistics.

Accessing CDP Driver Control

You can control the CDP driver using the CISCO-CDP-MIB.

Warning: Alter the CDP setting only in special cases. For example, you might restart the
CDP driver from the Control Panel at run timeto pick up thelatest | P configuration
changes without resetting the system.

SeeAlD

Installing the CDP Protocol Driver on page 56

Starting the CDP Protocol Driver on page 56

Enabling the CDP Protocol Driver on page 57

Showing the CDP Protocol Driver Properties on page 58
Updating an IP Address for the CDP Protocol Driver on page 58
Locating Updated CDP Driver and Interface Files on page 59

Installing the CDP Protocol Driver

The Cisco CRS installation process installs the CDP protocol driver. After completion of a
successful Cisco CRS installation, the CDP protocol driver resides in the list of device drivers
under the Windows Control Panel.

Starting the CDP Protocol Driver

Step 1
Step 2
Step 3

Step 4

Step 5
Step 6

Step 7

To start the CDP protocol driver, follow these steps:

Choose Start > Settings > Control Panel.
Double-click System.

Click the Har dwar e tab.

Click Device Manager.

The Device Manager window appears.
Choose View > Devices by connection.
Choose View > Show hidden devices.

Double-click CDP Protocol Driver.
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Step 8
Step 9

Step 10

Enabling the CDP Protocol Driver

Click the Driver tab.
Click Start to enable the driver (Default = Start).
Click OK.

Note: Choosing Startup Type=Demand keeps Start setting after a restart

SeeAlD

Installing the CDP Protocol Driver on page 56

Enabling the CDP Protocol Driver on page 57

Showing the CDP Protocol Driver Properties on page 58
Updating an IP Address for the CDP Protocol Driver on page 58
Locating Updated CDP Driver and Interface Files on page 59

Enabling the CDP Protocol Driver

Step 1
Step 2
Step 3

Step 4

Step 5
Step 6
Step 7
Step 8
Step 9
Step 10

Step 11

To enable the CDP protocol driver, follow these steps.

Choose Start > Settings > Control Panel.
Double-click System.

Click the Har dwar e tab.

Click the Device Manager button.

The Device Manager window appears.
Choose View > Devices by connection.
Choose View > Show hidden devices.
Double-click CDP Protocol Driver.

Click the Driver tab.

Choose Enable Device.

Click Next, and then click Finish to enable the device.

Click Close and restart the system.

SeeAlo

Installing the CDP Protocol Driver on page 56
Starting the CDP Protocol Driver on page 56
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Showing the CDP Protocol Driver Properties

Showing the CDP Protocol Driver Properties on page 58
Updating an IP Address for the CDP Protocol Driver on page 58
Locating Updated CDP Driver and Interface Files on page 59

Showing the CDP Protocol Driver Properties

Step 1
Step 2
Step 3
Step 4
Step 5

Step 6

To show CDP protocol driver properties, follow these steps:

Choose Start > Run.

In the Run field, type \WINNT\system32\drivers.
Click OK.

Right-click cdp.sys.

Choose Propertiesto show CDP driver properties.

Click OK.

SeeAlD

Installing the CDP Protocol Driver on page 56

Starting the CDP Protocol Driver on page 56

Enabling the CDP Protocol Driver on page 57

Updating an IP Address for the CDP Protocol Driver on page 58
Locating Updated CDP Driver and Interface Files on page 59

Updating an IP Address for the CDP Pratocol Driver

The CDP protocol driver runs on top of the existing Ethernet network interface card. You can
restart CDP when a new IP address is configured at run time.

To update the CDP protocol driver, restart CDP using the Windows Device Manager to update
the CDP driver with the new IP address information. You do not have to reset the system after
updating.

SeeAlso

Installing the CDP Protocol Driver on page 56

Starting the CDP Protocol Driver on page 56

Enabling the CDP Protocol Driver on page 57

Showing the CDP Protocol Driver Properties on page 58
Locating Updated CDP Driver and Interface Files on page 59
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Locating Updated CDP Driver and Interface Files

Locating Updated CDP Driver and Interface Files

Installing Cisco CRS updates these components:

e The CDP driver (cdp.sys) updates to the Windows 2000 driver directory
(WINNT\System32\Drivers\cdp.sys).

» The CDP Interface Library (cdpintf.dll) updates to the Windows 2000 System32 directory
(\WINNT\System32\cdpintf.dll).

» A Backup Regedit export file for reinstalling CDP registries updates to the bin directory
(\Program Files\Cisco\Bin\cdp2k101.reg). Use this file to restore the CDP registry in case
it becomes corrupted. This file restores the CDP registry to the
HKEY_LOCAL_MACHINE\SYSTEM\ CurrentControlSet\Services\CDP directory.

After running the cdp2k101.reg file, you must reset the system to restore the CDP registries.

Default CDP Settings

The following table shows the default CDP settings.

Table 10: Default CDP Settings
Description Default Value

Default Transmit Frequency |60 seconds

Default Time to Live 180 seconds

Default State CDP advertisement enabled
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Default CDP Settings
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Part 2: Troubleshooting

Part 2 of this guide provides help in diagnosing and correcting Cisco CRS problems.
Troubleshooting tips are included for the various components of the CRS system.
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Chapter 6

Diagnosing and Correcting Cisco CRS Problems

This chapter describes problems that you might encounter when using the Cisco Customer
Response Solutions (CRS) system. For each problem, this manual lists symptoms, possible
causes, and corrective actions that you can take.

This chapter assumes that you are familiar with the CRS Administration web interface, CRS
trace and log files, and various Windows administrative tasks. For more information, refer to
the Cisco Customer Response Solutions Administration Guide and your Windows documentation.

General Troubleshooting Steps

Step 1
Step 2
Step 3

Step 4

Step 5

Step 6

Step 7
Step 8

Step 9

The following troubleshooting steps can help you diagnose most problems with your Cisco
CRS products:

Verify that Cisco CallManager is running.
Verify that the LDAP Directory service is running.
Verify that the Cisco CRS Node Manager service is registered.

Verify that you uploaded the application.aef files to the repository using the Repository Manager
and that you refreshed the CRS Engine after making a change to an application.

Refer to the Release Notes for known problems.

Verify that the Cisco CRS Node Manager service is running under a user account with
Administrator privileges.

Stop and start the Internet Information Server (11S).
Save log files to prevent them from being overwritten.

Save the application (.aef) file.
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General Troubleshooting Steps

Step 10  Before debugging CRS Administration problems, turn on the Debugging trace level option for
the ADM subfacility.

The detailed output will be in the following file:
c:\program files\wfavvid\log\MADM\jvm.stdout
The error output will be in the following file:

c:\program files\wfavvid\log\MADM\jvm.stderr
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Troubleshooting Tips

The following sections provide help in correcting problems with Cisco CRS software.

If you experience problems when using the Cisco Agent Desktop or the Cisco Supervisor
Desktop, see the Troubleshooting section of the Cisco CAD Service Information Guide book,
located at http://www.cisco.com/univer cd/cc/td/doc/product/voice/sw_ap_to/apps 4 0/
english/agents/cad611si.pdf.

If you are using Cisco IPCC Express with Cisco ICM Software as part of the IPCC Gateway
Solution and you experience any problems, see the troubleshooting information in the Cisco
IPCC Gateway Deployment Guide.

Note: The following troubleshooting tips are also accessible from the CRS Administration user
interface. To access them from the Main menu, select Tools > Troubleshooting Tips.

Cisco CallManager Automated Attendant problems

The following sections provide help with CallManager Automated Attendant problems.

Dial by name does not find the specified server

Symptom:

The Cisco CallManager Automated Attendant cannot find a user that a caller specifies when
dialing by name.

M essage:
None.
Cause

The extension of the requested user is not valid because the user does not have a primary
extension assigned in Cisco CallManager, or the cendir.ini file is missing information.
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Troubleshooting Tips

Cisco IPCC Express Problems
Action:
Complete the following steps:
1. Inthe Cisco CallManager User Information web page, verify that the user has an entry in
the AutoAttendant Dialing field, that the User record has an associated phone, and that

the Primary Extension radio button is selected.

2. On the CRS server, verify that the ccndir.ini file contains the correct userbase and
profilebase information. For example:

# Base DN for CCN APPS

CCNAPPSBASE "ou=CCN Apps, o=cisco.com"
# CCN Cluster Profile name
CCNCLUSTERPROFILE "johndoe_ test"

# Base DN for Users

USERBASE '‘ou=Users, o=cisco.com"

Automated Attendant prompt is not played
Symptom:
The Cisco CallManager Automated Attendant prompt is not played.
M essage:
None.
Cause:

An incorrect welcome prompt is specified in the welcomePrompt field in the Cisco Script
Application web page.

Action:

From the CRS Administration web page, choose Applications > Prompt M anagement. Click
the Upload New Prompts link to upload the Welcome prompt.

Cisco IPCC Express Problems

The following sections provide help with common IPCC Express problems:
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RM-CM subsystem is out of service

Symptom:

The Resource Manager Contact Manager (RM-CM) subsystem is out of service.

M essage:

None.

Cause:

The RM JTAPI user in Cisco CallManager is not configured properly.

Action:

Complete the following steps:
1. From the CRS Administration web page, choose Subsystems > RmCm.
2. Click the RM JTAPI Provider hyperlink.

3. Make sure that the information in the RM JTAPI User ID and Password fields matches
the information for the RM JTAPI user in Cisco CallManager.

RM-CM subsystem remains INITIALIZING

Symptom:

The Resource Manager Contact Manager (RM-CM) subsystem remains in INITIALIZING
state.

M essage:

None.

Cause:

Could not load the default scripts CM.aef and RM.aef.

Action:

Complete the following steps:
1. Check the RM JTAPI provider configuration and then stop and restart the CRS engine.
2. Check to be sure the workflow scripts CM.aef and RM.aef are present on the Script

Management page on CRS Administration. They are needed for the RM-CM subsystem
to be in service. If either of these scripts are deleted, missing, or corrupted, the RM-CM
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subsystem will not go IN SERVICE. To recover, upload new copies of these scripts from
C:\Program Files\wfavvid\scripts\system\default\rmcm, and restart the
CRS Engine.

RM-CM remains in Initializing state

Symptom:

The RM-CM subsystem remains in the Initializing state after the CRS Engine starts.
M essage:

None.

Cause:

The RM-CM subsystem is unable to read any configuration information.

Action:

Make sure there is at least one "CRS SQL Server - Config" service running in the cluster. If the
service is stopped, start it.

Agents, Supervisors, or Teams are out of synch

Symptom:

Agents, Supervisors, or Teams are out of synch between IPCC Express and the Cisco Desktop
Administrator.

M essage:
None.
Cause:

The automatic synchronization between IPCC Express and the Cisco Desktop Administrator
failed.

Action:

Launch a manual synch from the Cisco Desktop Administrator by selecting the Logical Call
Center (usually the CRS profile name) and clicking Setup > Synchronize Directory Services.

Agent or CSQ does not appear in Cisco Desktop Administrator

Symptom:
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After adding an agent or a contact service queue (CSQ) in CRS Administration, the agent or
the CSQ does not appear in the Cisco Desktop Administrator.

M essage:

None.

Cause:

The RM-CM subsystem has not synchronized the agents.
Action:

Go to the Resources link under Subsystems > RmCm. This will force the RM-CM subsystem
to synchronize the agents.

Agents do not appear in the Resources area in the IPCC Express Configuration web page

Symptom:

No agents appear in the Resources area in the IPCC Express Configuration web page.
M essage:

None.

Cause:

To appear as an agent in this area, a user must be configured as an IPCC Express agent in the
Cisco CallManager User Information web page.

Action:
In Cisco CallManager, verify configuration information in the User Information web pages. For

each user, under Associated Devices, verify that a phone is associated, and verify that the IPCC
Express extension radio button is selected.

IPCC Express radio button is not available

Symptom:

The IPCC Expressradio button is not available in the Cisco CallManager Associated Devices
web page.

M essage:
None.

Cause:
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An error occurred during the installation process.
Action:

Perform the following steps to modify the system profile object in the LDAP directory and set
the 1AQ flag to true:

1. Log in to the LDAP server using DC Admin or another administration program (such as
ADSI Edit for Active Directory).

2. Navigate to the following location: CCN > systemProfile.

3. Right-click SystemProfile, and then set the IAQ Flag under the Application Install Status
tab to true.

4. Wait 15 minutes or restart the 11S and its dependent services.

You cannot select the order of agents

Symptom:

When you configure a resource group, the system does not allow you to select the order of
agents.

M essage:

None.

Cause:

You order agents at the CSQ level.
Action:

When you configure the CSQ and select the desired Resource Group, click Show Resour ces
and order the agents as desired.

Agent does not go to Work state after handling a call

Symptom:

An agent does not go to Work State after handling a call, even though the CSQ is configured
with Auto Work turned on.

M essage:
None.

Cause:
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An agent will not go to Work State after handling a call if the agent presses the Ready button
while in Talk state. In addition, if the agent services multiple CSQs, Auto Work may not be
configured for each CSQ. The agent will only go to Work State if the call comes from a CSQ
where Auto Work is enabled.

Action:

None.

A media step causes a Could not create PlayPromptDialog Object exception

Symptom:

Any media step except SendDigitString causes the following exception in the CRS trace files.
M essage:

Could not create PlayPromptDialog Object:

Exception=com.cisco.channel .ChannelUnsupportedException:
com.cisco.dialog.PlayPromptDialog is not supported.

Cause:

A Primary Dialog Group was not specified when a trigger was defined.

Action:

After you add an application in the CRS Application Configuration web page, you must define

a trigger. When you define a trigger for the application, you must define both a Call Control
Group and a Primary Dialog Group in the JTAPI Trigger Configuration window.

Unable to make any IPCC Express configuration changes

Symptom:

When trying to save IPCC Express configuration changes, CRS Administration shows an error
message.

M essage:

There was an error reading/updating the database. Please contact your
administrator.

Cause:
All"CRS SQL Server - Config" services need to be IN-SERVICE in order to make IPCC Express
configuration changes. If one or more services are down, no IPCC Express configuration update

is allowed.

Action:
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Check the state of all "CRS SQL Server - Config" services in the cluster. If a service is stopped,
start it. Make sure the "CRS Config Datastore” component is activated.

Some resource selection criteria are missing

Symptom:

When trying to configure a CSQ, CRS Administration does not show all the resource selection
criteria.

M essage:

None.

Cause:

The CSQ is resource-group based. A resource-group based CSQ has Longest Available, Most
Handled Contact, Shortest Average Handle Time, Linear and Circular criteria. A skills-based
CSQ has Longest Available, Most Handled Contact, Shortest Average Handle Time, Most
Skilled, Least Skilled, Most Skilled by weight, Least Skilled by Weight, Most Skilled by Order,
and Least Skilled by Order criteria.

Action:

You might want to use a skills-based CSQ in order to use a specific resource selection criteria.

Unable to record an agent

Symptom:

A supervisor is unable to record an agent's call. Clicking on Record pops up a message dialog
box.

M essage:

Unable to record agent.
Cause:

The recording count is set to 0.
Action:

Go to CRS Administration. Select System > System Parameter s and set the number of the
recording count appropriately.

Calls to IPCC Express route points are disconnected

Symptom:
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Callers are disconnected when calling IPCC Express route points.

M essage:

None.

Cause:

The CSQ parameter is not correctly defined in the Cisco Script Application web page.
Action:

From the CRS Administration web page, choose Applications > Application M anagement,

click the name of the script that corresponds to IPCC Express, and then enter the name of the
configured CSQ in the CSQ field.

Calls are not routed to agents

Symptom:

Calls are not routed to agents even though the agents are configured with the skills of the CSQ.
M essage:

None.

Cause:

The skill levels of the agents are not equal to or higher than the skill levels of the CSQ.
Action:

Click Show Resources on the CSQ configuration page to determine that agents are part of the

CSQ. If agents do not appear, verify that the skill levels of the agents are equal to or higher than
the skill levels of the CSQ.

Agents do not show ina CSQ

Symptom:

A CSQ is configured with a group of agents for Skill A and a group of agents for Skill B;
however, the agents do not show up in the CSQ.

M essage:
None.

Cause:
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Agents do not have all the skill levels of the CSQ or the skill level of the agents do not have
equal or higher skill levels than that of the CSQ.

Action:

Verify that agents have all the skill levels of the CSQ and that the agents have equal or higher
skill levels than that of the CSQ.

Caller gets dropped when an attempt is made to recall an IPCC Express agent extension after the agent previously parked

the call

Symptom:

Agent A gets an IPCC Express call and parks that call. After the parked call times out, a recall
is attempted to the Agent A extension (if no other agent has picked up the call). If Agent A is
busy handling another call on that IPCC Express extension while the previously parked call is
being routed, the caller gets dropped.

M essage:
None.
Cause:

A parked call gets dropped if an attempt is made to place the call again to a busy line that is not
set with forward busy.

Action:

Configure the IPCC Express extension of Agent A with Forward Busy to a non-IPCC Express
line on the same phone. Also, configure this line as Forward Busy to the IPCC Express route
point. When an attempt is made to recall the IPCC Express extension of Agent A, the call is
forwarded to the non-1IPCC Express line if the extension is busy. If the non-IPCC Express line
is busy, the call is forwarded to the IPCC Express route point and gets queued again instead of
being dropped. You can set up the workflow of the IPCC Express route point to increase the
priority of the call.

Updating a NIC driver disables silent monitoring and recording

Symptom:

After updating a network interface card (NIC) driver, the Cisco Supervisor Desktop and Cisco
Agent Desktop Silent Monitoring and Recording features do not work.

M essage:
None.

Cause:
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This problem can occur if you have updated a NIC driver on a server on which you checked
the VoIP Monitor Server check box during the installation of Cisco CRS.

Action:

Reinstall Cisco CRS. Make sure to check the VoIP Monitor Server check box in the Component
Distribution pane.

Cisco IP IVR Problems

The following sections provide help with IP I\VVR problems:

Cisco IP IVR drops callers when transferring to an extension

Symptom:

After Cisco IP IVR transfers a call to an extension, the called party hears a busy signal when
taking the call and the caller is dropped.

M essage:

None.

Cause:

If a call gets dropped, one potential cause is a codec mismatch between the endpoint and the
CRS Server. The CRS Server supports either the G.729 or the G.711 protocol, but not both
simultaneously. To support these protocols, a transcoder is required.

Action:

Install a transcoder for Cisco IP IVR.

Prompts play in language
Symptom:
A script was assigned to a language at the route point but it plays prompts in another language.
M essage:
None.

Cause:
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This problem can be caused by the following situations:
» The system default language is set incorrectly.
» The language specified in the Set Contact step is incorrect.

» The language specified in the Play Prompt step is incorrect.

Action:

Verify that system default language is set correctly. Verify that the correct language is set in
the Set Contact step or the Play Prompt step if these steps are used.

Some prompts do not play

Symptom:

A prompt in a script does not play. The script may or may not continue executing.

M essage:

None.

Cause:

A prompt is missing in the language directory for the language used by the script. By default,
the Play Prompt step is set to continue if it encounters an error and the script will continue to
play if it encounters a missing prompt. If you have changed the Play Prompt step to not continue
if it encounters an error, the script will stop executing.

Action:

Refer to the CRS trace files to find the missing prompt. Provide the missing prompt in the
language folder shown in the CRS trace files.

Some prompts in a script play in the language specified and other prompts play in English

Symptom:

A script is set to a language other than US English, but some prompts play in US English.
M essage:

None.

Cause:
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A prompt is missing in the language directory for the language used by the script. If the default
language for the script uses the same rules as US English, the system will automatically replace
the missing prompt with a US English prompt.
Action:

Refer to the CRS trace files to find the missing prompt and provide the missing prompt in the
language folder shown in the CRS trace files.

A prompt plays phrases in the wrong order

Symptom:

A prompt played by the Create Generated Prompt step plays the correct language but plays
phrases in the wrong order. For example, a prompt that you expect to play as “month, day, year”
plays as “year, month, day.”

M essage:

None.

Cause:

The Create Generated Prompt step is using incorrect rules for the language.

Action:

If creating a new language or adapting an existing language for a new locale, check the
PromptGenerator.properties file and make sure that it is using the correct rules for the language.

CRS Administration Problems

The following sections describe how to correct problems with CRS Administration.

The CRS Administration Authentication web page is not available

Symptom:

You cannot browse to the CRS Administration URL and a Page Cannot be Displayed error
appears.

M essage:
None.

Cause:
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The system cannot access the CRS Administration web page. A required service may not be
running or required files may be missing.

Action:

Make sure the following services are running:

» Check that the CRSJavaAdmin.exe is running (in Windows Task Manager).

 1IS Admin service

» World Wide Web Publishing service

If these services are running, verify that files exist in the
install_directory\tomcat_appadmin\webapps\appadmin\ directory, where install_directory is
the folder in which the CRS system is installed. (By default, the CRS system is installed in the
c:\Program Files\wfavvid folder.)

I no files exist in this directory, perform the following steps:

1. Stop the Cisco CRS Node Manager service.

2. Delete the appadmin folder from the tomcat_appadmin\webapps folder in the folder in
which you installed the CRS system. (By default, the CRS system is installed in the
c:\Program Files\wfavvid folder.)

3. Start the Cisco CRS Node Manager service.

4. Wait for a few minutes and try to browse to the URL again.

Uploading a license file can result in a warmning message

Symptom:

The user gets a warning message when uploading license files using CRS Administration.

M essage:

The license file, <filename>, if uploaded will change the package from
<existing license package> to <new license package>. Please click OK
to continue or CANCEL to abort.

Cause

This warning is only displayed if a user tries to upload licenses which change the existing license
package of the CRS cluster to a different package.

Action:
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The user needs to determine if he or she really wants to change the license package as described

in the warning message. If yes, clicking OK will change the package. If it was a user error,
clicking CANCEL will keep the license package unchanged.

Unauthorized web page appears when you try to log in

Symptom:

After you enter a User Identification and Password and click Log On in the CRS Administration
Authentication web page, the Unauthorized web page appears.

M essage:

Unauthorized. Please try again. You failed to authenticate yourself
while requesting a document that requires authentication. Please use
the browsers back button to go back to the login page.

Cause

You entered an incorrect ID or password, you have not been configured properly in CRS
Administration, or the DC Directory Server service (or another LDAP service) is not running.

Action:
Complete the following steps:
1. Make sure that you are using a User ID that is a configured as Administrator. Even though
a user exists in Cisco CallManager, a user must be configured as Administrator in CRS
Administration.

2. User ID and Password are case sensitive, so make sure that you enter these items correctly.

3. Make sure that the DC Directory Server service running. Or, if you have specified another
LDAP as the active directory, make sure that service is running.

User cannot log in to the CRS web page
Symptom:
A user cannot log in to the Cisco CRS web pages after the CRS Administration times out.
M essage:
None.
Cause:

If you perform no activity for 30 minutes, the CRS system automatically logs you out.

Cisco Customer Response Solutions Servicing and Troubleshooting Guide 4.0(x)

79




Troubleshooting Tips

CRS Administration Problems
Action:

Log in again to continue.

Refreshing subflow script does not update parent scripts

Symptom:

Refreshing a subflow script does not update its parent scripts.
M essage:

None.

Cause:

If a script is referenced in other scripts, refreshing a subflow script does not update its parent
scripts.

Action:

Manually refresh all parent scripts.

User deleted from CallManager cannot log CRS
Symptom:
A user who is deleted from Cisco CallManager cannot log in to Cisco CRS.
M essage:
None.
Cause:

If only one user is configured as Administrator in CallManager and that user is deleted from
CallManager, that user will not be able to log in to Cisco CRS.

Action:
You can work around this problem in one of the following ways: Add the user in Cisco

CallManager with the same user name and password that the user has in CRS. The user can
then log in to CRS.
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Or follow these steps:

1. Log into DC Directory and browse to Directory > cisco.com > CCN Apps >
configurations > cluster profilename name _$$CRS40$$_ > usergroup.

2. Click users?array in the right pane.

3. Right-click users?array and choose Properties.

4. In the Properties window, click the value in the Value area and then click M odify.
5. Click Remove and then click OK.

The user will then be able to log in to CRS using the “Administrator” 1D.

CallManager users display in random order

Symptom:

On the CRS User Maintenance window, CallManager users display in random order when the
number of users returned during the search is greater than 75.

M essage:

None.

Cause:

The User Maintenance window on Cisco CRS limits the display to 75 CallManager users. If
that number is exceeded, the CallManager users display in a random order. Instead of the usual
logical order of 39001, 39002, 39003, 39004, the list contains 39001, 39003, with 39002 and
39004 not shown.

Action:

Narrow the search by adding additional characters to be matched.

CRS Supervisor web page cannot be viewed from CRS Server
Symptom:
The Cisco CRS Supervisor web page cannot be viewed from the Cisco CRS Server.
M essage:
None.

Cause:
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If the Cisco CRS Supervisor is running on a computer with the language set to Simplified
Chinese, you cannot view the Cisco CRS Supervisor web page from the Cisco CRS Server.

Action:

Use a client computer to view the Cisco CRS Supervisor web page.

Database table fields used by wallboard store data in milliseconds

Symptom:

Some database table fields used by a wallboard store data in milliseconds instead of in
HH:MM:SS.

M essage:

None.

Cause:

The avgTalkDuration, avgWaitDuration, longestTalkDuration, longestWaitDuration, and
oldestContact database table fields in the RtCSQsSummary and the RtICDStatistics database
tables store date in milliseconds.

Action:

If you want to include information described by these fields on your wallboard, use the following
fields, which store the same information but use the HH:MM:SS format:

Instead of avgTalkDuration, use convAvgTalkDuration.

Instead of avgWaitDuration, use convAvgWaitDuration.

Instead of longestTalkDuration, use convLongestTalkDuration.

Instead of longestWaitDuration, use convLongestWaitDuration.

Instead of oldestContact, use convOldestContact.

Management pages display error message when selected

Symptom:

The Prompt Management, Grammar Management, or Document Management pages show an
error message when selected.

M essage:
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com.cisco.file_FileException: Unable to list files; Repository Data
Store not initialized

Cause

This error occurs when there is no master selected for the Repository Datastore component.
This can happen due to one of the following reasons:

» Repository Datastore component is not activated at all in the cluster.

» Repository Datastore component activated node is not up or SQL Services are not running
on this node.

 In the case of high availability, the Repository Datastore component is activated, but the
Publisher activation has not yet completed from the Datacontrol Center page of CRS
Administration.

Action:

To resolve the problem, do one of the following:

+ To activate the Repository Datastore component, from CRS Administration select Control
Center > Component Activation page. Check to be sure the nodes with Repository Datastore
components are up and running. If the nodes are up, check that all the SQL Services, including
Microsoft SQL Server and Microsoft SQL Agent services are up and running.

* In the case of high availability, from CRS Administration, go to Datacontrol Center >
Publisher Activation page to check that the Publisher is activated . If active, you see the

Publication Snapshot Agent in STOPPED state and the Subscription Agent in RUNNING
state.

Zip file does not auto unzip on Document Management page

Symptom:

On the Document Management page when a zip file is uploaded, it does not get unzipped
automatically as a zip file does on the Prompt Management and Grammar Management pages.

M essage:
None.
Cause

While uploading a zip file in Document Management, the user has the option of storing it as a
zip file without unzipping or unzipping the file before it gets stored.

Action:
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Be sure the Unzip after uploading check box is selected if that is the intention.

Invalid files message displays while uploading a zip file of prompts

Symptom:

Uploading a zip file of prompts (or grammars or documents) at the root level in Prompts
Management (or Grammar Management or Document Management) shows an error message
in the MADM log files..

M essage:

Invalid Files...

Cause:

This problem could occur for one of the following reasons:

+ At the root level only language folders can exist.

» Prompt Management and Grammar Management pages except files of valid extension only.

Action:
To correct the problem, do the following:

» Check that your zip file does not contain any files that do not belong to a folder while
uploading at the root level.

» Check that all the files have a valid extension.

A Component Manager goes into partial service when uploading a zip file

Symptom:

When uploading afile or zip file from Prompt Management, Grammar Management, or Document
Management in CRS Administration, the CRS Engine component Prompt Manager (or Grammar
Manager or Document Manager) is shown in PARTIAL_SERVICE state.

M essage:

PARTIAL_SERVICE

Cause:

The Prompt Manager, Grammar Manager, or Document Manager are put in PARTIAL_SERVICE

by File Manager while it synchronizes the uploaded files from the Repository Datastore to the
local disk. Once the synchronization is complete, they are put back into INSERVICE state.
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Action:

None.

All user records not displayed on CRS User Management web page

Symptom:

All of the expected user records are not displayed on the Cisco CRS User Management web
page.

M essage:
None.
Cause

The default number of records that an Active Directory search returns is 1,000. If there are more
than 1,000 records of users in your corporate directory, some of them will not display on the
web page.

Action:

You can increase the number of users displayed by increasing the default Active Directory
search limit or by adding users to an LDAP entry. To increase the default Active Directory
search limit, follow these steps:

1. Log into the Active Directory server using an administrator account and open a command
prompt.

2. At the command prompt, type ntdsutil and press Enter.
The command prompt changes to nudsutil :.

3. Type LDAP Paliciesand press Enter.
The command prompt changes to Idap policy:.

4. Type connectionsand press Enter.
The command prompt changes to server connections:.

5. Type the following command, where nameis the DNS name of the Active Directory server
on which you are entering the command:

connect to server %name%
Press Enter to bind to the Active Directory server.

6. Press q and press Enter.
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The command prompt changes to Idap policy:.
7. Type Show Values, press Enter, and determine the current setting for MaxPageSize.

8. Type the following command and press Enter to increase the MaxPageSize limit, where
limit is the new limit to set:

Set MaxPageSize to limit
9. Type Commit Changesand press Enter.
10. Type Show Values, press Enter, and confirm the change to the MaxPageSize setting.
11. Type g and press Enter until the original Windows command prompt appears.

12. Stop and then restart the CiscoCRSServletEngine service.

To add users to the LDAP entry, complete the following steps:
1. Use atool such as ADSI Edit to modify the following LDAP entry:
Cisco > CCN Apps > Configurations > usergroup.xxxxxxx/users?array
2. Add users to the property CiscoCCNatConfiginfoCESValue in this LDAP entry. Enter
users in the following format, where (1) specifies administrator access and (2) specifies

Supervisor access:

userID(1) or userID(2)

High call rejection rate under heavy load
Symptom:
With a heavy load of over 200 agents a high call rejection or aborted rate occurs.
M essage:
None.
Cause:

Writing the CallManager and CTIl Manager traces to the local drive leads to call failures due to
the increased load of tracing.

Action:
CTI Manager and CallManager traces need to be directed to another hard drive. Here is an

example of how to set things up. Note that you need to create the directory structure shown in
the F:\ drive:
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CallManager SDL Trace Directory Path = F:\Program Files\Cisco\
\Trace\SDL\

CallManager SDI Trace output setting, File Name = F:\Program
Files\Cisco\Trace\CCM\ccm.txt

CTIManager SDL Trace Directory Path = F:\Program Files\Cisco\ Trace\SDL\

CTIManager SDI Trace output setting, File Name = F:\Program
Files\Cisco\Trace\CCM\cti .txt

The AntiVirus has been set not to scan the following folders:

C:\Program Files\Cisco\Trace\ F:\Program Files\Cisco\Trace\

CRS Database Problems

The following sections describe how to correct problems with the CRS Database.

CRS Databases are not purged as expected

Symptom:

The CRS databases are not automatically purged as expected.
M essage:

None.

Cause:

The cause of this problem could be one of the following:

« Automatic purging is not configured properly.

» You have changed the system clock on the CRS server.

* You have altered the size of the CRS databases.

Action:
Depending upon the cause of the problem, do one of the following:

» From the CRS Administration web page, choose Tools> Historical Reporting and configure
automatic purging.

« If you change the size of the CRS databases, make sure that the CRS database size is equal
to the maxsize.
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Historical Database db_cra is full due to high availability

Symptom:

Historical data is not getting written into the database, db_cra, while running a high availability
setup.

M essage:

Could not allocate space for object in database db_cra because the PRIMARY file group is full
in the SQL log file, MIVR log file.

Cause:
The cause could be one of the following:
» The db_cra database is full.

» Most of the database content is replication system meta data because of high availability.

Action:
Depending upon the cause of the problem, do one of the following:

1. Try to start purging using the CRS Administration web page. Choose Tools > Historical
Reporting > Purge Now.

2. Check the db_cra database size to make sure that it is of the proper size for the call volume
generated.

E-mail notification of database purging activities is not sent

Symptom:

The CRS system does not send e-mail notification of database purging activities.
M essage:

None.

Cause:

The Email subsystem is not configured or e-mail notification is not set up properly in CRS
Administration.

Action:
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Complete the following steps:

1. From the CRS Administration web page, choose Subsystems > eM ail and make sure that
correct information is entered in the Mail Server and eMail Address fields.

2. From the CRS Administration web page, choose Tools > Historical Reporting and click
the Purge Schedule Configuration hyperlink.

If multiple e-mail addresses are specified in the Send Email Notifications To field, make
sure that each address is separated with a semicolon (;), comma (,), or space.

Make sure that the Send Email Notifications To field contains no more than 255 characters.

Syslog or SNIMP trap notification of database purging activities is not sent

Symptom:

The CRS system does not send Syslog notification or SNMP trap notification of purging
activities.

M essage:
None.
Cause

The Cisco AVVID Alarm Service is not running, Syslog is not configured, or SNMP service is
not configured.

Action:

Complete the following steps:
1. Make sure that the Cisco AVVID Alarm Service is running.
2. Make sure that Syslog is properly configured.

3. Make sure that SNMP service is properly configured on the CRS server.

CRS Editor Problems

The following section describes common problems with the CRS Editor.

Change a string variable to an integer

Symptom:
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You want to change a string variable to an integer.
M essage:

None.

Cause:

None.

Action:

Use the Set step, which supports the conversion of a string to any numerical type.

Accept step error during active debug

Symptom:

While debugging an application, the following message appears, where n is the task 1D:

M essage:

Task: nAccept Step: Trigger is not a Contact Application trigger.
Cause:

The debugger encountered the Accept step in the application but there was no call to answer.
Action:

Debug the application as a Reactive Application and make the call before the Reactive
Application times out.

Error occurs with Reactive Debugging Tool

Symptom:

An error occurs when using the Reactive Debugging tool.

M essage:

Not defined.

Cause:

Using the CRS Editor Reactive Debugging tool on a translation routed call can cause an error.

Action:
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From the ICM Configuration Manager, choose Tools> List Tools> Network VRU Script
List and temporarily increase the value in the Timeout field for the script.

CRS Engine Problems

The following section describes common problems with the CRS Engine.

Voice Browser step throws an exception

Symptom:

When the URL specified in Voice Browser step uses "ServerName" instead of IPAddress, the
step throws an exception, "UnknownHostException."

M essage:
None.
Cause:

The Java Virtual Machine (JVM) caches a previously resolved entry, that is no longer correct,
until the JVM is restarted.

Action:

Restart the CRS Engine.

CRS Engine does not start and an RMI port in use error appears

Symptom:

The CRS Engine does not start and an RMI port in use error appears in the CRS trace files.
M essage:

RMI port in use.

Cause:

Another process is using the port that the CRS Engine is attempting to use.

Action:
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From the CRS Administration web page, complete the following steps:
1. Choose System > System Parameters.
2. Enter a different port in the RMI Port Number field.
3. Stop and then restart the CRS Engine.

4. If CRS Engine is shown "Invalid" from CRS Administration, see the troubleshooting tip
Service constantly shows Invalid (page 145).

Enterprise Data and VolP Subsystems are out of service

Symptom:

Enterprise Data subsystem and VoIP subsystem are out of service on the primary node after
upgrading the primary Cisco CRS server (the server which has the primary engine).

M essage:
None.
Cause:

The cluster has two engine nodes (primary and secondary node) and the primary node is upgraded
(or repaired). The primary node is the current engine node before the upgrade.

Action:
Do the following:

 Before starting the upgrade/repair on the primary node, manually fail over the engine to the
standby node.

Note that before doing this, both the primary and secondary engine nodes should be up and
running and the secondary node should be the current engine master.

» Then start upgrading the primary node.
Note: If you upgraded the primary node without following the above procedure, do a re-elect

master once the primary node is upgraded. The subsystems will come up once the engine fails
over to the upgraded node..

Attempting to start the Cisco CRS Node Manager service causes an error 1067

Symptom:

You attempt to start the Cisco CRS Node Manager service in the Windows Services window
and the following message appears.
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M essage:

Could not start the Cisco CRS Node Manager service on local computer.
Error 1067: The process terminated unexpectedly.

Cause:
There is an internal error in the Cisco CRS Node Manager.
Action:

Refer to Cisco Customer Response Solutions Administration Guide or the Administration online
help for information about properly setting up the CRS Node Manager service.

Attempting to start the Cisco CRS Node Manager service causes an error 1069

Symptom:

You attempt to start the Cisco CRS Node Manager service in the Windows Services window
and the following message appears.

M essage:

Could not start the Cisco CRS Node Manager service on local computer.
Error 1069: The service did not start due to a logon failure.

Cause:

When you install Cisco CallManager or Cisco CRS, the Windows 2000 administrator password
that you enter overwrites the existing Windows 2000 administrator password. Also, if you enter
a password that includes spaces, it may not be recorded properly.

Action:

Perform the following steps to change the password for the CRS Node Manager service:

1. On the CRS Server, choose Start > Settings > Control Panel > Administrative Tools
> Services.

2. Double-click Cisco CRS Node Manager .
3. Choose the Log On tab.

4. Enter and confirm the Windows 2000 administrator password and click Apply. Do not
include spaces in the password.

Application subsystem is in partial service

Symptom:
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The Engine Status area in the Engine web page shows that the Application subsystem is in
partial service.

M essage:
None.
Cause:
Some applications are invalid.
Action:
Performs these actions:
1. Refer to the CRS trace files to identify the invalid application.

2. Validate the corresponding script using the CRS Editor.

Remote database is unavailable; File Manager goes into partial service

Symptom:

If you have custom jar files uploaded to the defaul t\classpath folder through the Document
Management page and they do not replicate to the local disk (c:\program
files\wfavvid\documents\user\default\classpath) directory, then this could be
due to the remote database node(s) being down. In the CRS Administration Control Center,
under CRS Engine and CRS Administration, the File Manager service shows PARTIAL
SERVICE.

M essage:
FileException: Repository datastore not initialized.
Cause:

Custom jar files stored in Repository Datastore (on the remote database) are copied to local disk
by CRS Administration and CRS Engine during their startup. If at their startup the remote
database node is not running, then the copying of the custom jar files fails with the above error,
and File Manager service goes into PARTIAL SERVICE.

Action:

After the remote database is up and running and you have configured the custom classpath and
uploaded the jar files to the default\classpath folder on the Document Management page,
restart the CRS Engine service and the CRS Administration from the Administration Control
Center. The custom jar files are then copied to the local disk from the Repository Datastore.
After doing this, you see that the File Manager service shows the IN SERVICE state. If you are
using the CRS Editor, close the Editor and start it again.
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CRS Engine is running but calls are not answered

Symptom:

The CRS Engine is running but the CRS system does not answer calls.

M essage:

None.

Cause:

The JTAPI subsystem is out of service, the trigger is disabled, the application is disabled, the
maximum number of sessions or maximum number of tasks were exceeded, or no CTI ports or
media channels are available for the trigger.

Action:

Complete the following steps:

1.

From the CRS Administration web page, choose System > Control Center, pick up the
servers on the left panel, and expand the CRS Engine to verify that the JTAPI subsystem
is in service.

If the JTAPI subsystem is in partial service, see the “JTAPI subsystem is in partial service”
troubleshooting tip in this guide.

If the JTAPI subsystem out of service, refer to the “CRS Provisioning for Cisco
CallManager” section in the Cisco Customer Response Solutions Administration Guide
for information about configuration.

From the CRS Administration web page, choose Subsystems > JTAPI and click the
JTAPI Triggershyperlink. If False appears in the Enabled column for the trigger,
double-click the trigger, click the Enabled Yesradio button, and then click Update.

From the CRS Administration web page, choose Applications> ConfigureApplications.
If No appears in the Enabled column for the application, double-click the application, click
the Enabled Yesradio button, and then click Update.

In the CRS trace files, verify that the calls do not exceed the maximum number of allowed
sessions.

In the CRS trace files, verify that the calls do not exceed the maximum number of allowed
tasks.

In the CRS trace files, make sure that there are no messages regarding insufficient free
CTI ports or media channels.

Cisco Customer Response Solutions Servicing and Troubleshooting Guide 4.0(x)

95



Troubleshooting Tips

CRS Engine Problems

Changing the time on CRS machines results in agents getting logged off

Symptom:

Agents got logged off and Cisco Agent Desktop out-of-service and wrap-up timer delay expired
when the time was changed on CRS.

M essage:
None.
Cause

If wrap-up timers are being used on Cisco Agent Desktops, changing the CRS time can cause
erroneous firings of the timers.

Action:

Do not change the system time on CRS machines.

An error message plays when calling a CTl route point

Symptom:

Callers hear a message when calling a CTI route point. The JTAPI subsystem might also be in
partial service because the CTI route point cannot load the associated application script.

M essage:

I"m sorry, we are currently experiencing system problems.
Cause:

The application script associated with the CTI route point did not load correctly.

Action:
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Validate the application script in the CRS Editor as follows:

1.

2.

From the CRS Administration web page, choose Scripts > Manage Scripts.

Click the script and download it from the Repository.

Open the script in the CRS Editor.

Validate the script and save it.

Choose Scripts > Manage Scriptsand upload the script to the Repository.

When prompted, click Yesto refresh both script and applications.

Refer to the CRS trace files to verify that the application script was loaded successfully.
If a script has been validated, saved, and uploaded to the repository, and still will not load,

verify that any other dependencies are met. For example, if the script references a custom
class, make sure that the class is available to the CRS Engine.

Changes to applications do not register

Symptom:

You make changes to an application script but the changes are not apparent to callers.

M essage:

None.

Cause

The application script was not uploaded to the repository and refreshed.

Action:

After making a change to an application script, perform the following steps:

1. Save the application script.

2. From the CRS Administration web page, choose Scripts > Manage Scriptsand upload

the application script to the repository.

3. When prompted, click Yesto refresh both script and applications.

Call drops during transfer over gateway

Symptom:
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When the CRS system receives a call made over a gateway, the CRS system drops the call if
the call is transferred.

M essage:
None.
Cause:

The H.323 client does not support the Empty Capability Service and the H.323 port on the Cisco
CallManager is not configured to use a Media Termination Point (MTP).

Action:

Update the configuration of the Cisco CallManager H.323 port to require an MTP and reset the
H.323 port.

H.323 client DTMF digits not detected

Symptom:

When a call originates from an H.323 client, DTMF digits are not collected.
M essage:

None.

Cause:

The H.323 client only produces in-band DTMF signals. Cisco CallManager cannot detect in-band
DTMF signals.

Action:

None.

Redirected call is disconnected

Symptom:

A redirected call disconnects or a redirected call does not ring the IP phone to which it was
directed.

M essage:
None.
Cause:

Some gateways do not support ringback.
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Action:
Reconfigure the gateway and protocols so that they will support ringback.

Following are the gateways and the protocol for each gateway (note that the protocol is in
parentheses):

o 26XX FXO (Media Gateway Control)

* 36XX FXO (36XX FXO Media Gateway Control)
* VG200 FXO (Media Gateway Control)

« DT-24+ (Skinny)

« WS-6608-T1—[Cat6K 8-port T1 PRI] (Skinny)

. WS-6608-E1 [Cat6K 8-port E1 PRI] (Skinny)

» DE-30+ (Skinny)

« AT-2,4,8(AT-2,4,8—)

The CRS server runs out of disk space

Symptom:

Possible symptoms are:

 An out of memory error occurs on the CRS server.

« Accessing purging or synchronization pages on the Administration Ul returns an error.

 Running historical reports returns SQL error 5048.

M essage:

SQL error 5048.

Cause:

The CRS database log files, the tempdb database, or the tempdb log files have grown large.
Action:

There are two possible actions you can take:

1. To manually shrink a CRS database log file, open a command window on the CRS server
and type the following commands:
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osgl -Usa -Ppassword -ddb_cra, where password is the password for the sa log in to the
CRS database.

USE database name, where database nameis db_cra.
GO
DBCC SHRINKFILE (database_name_log.mdf), where database_name is db_cra.
GO
2. Alternatively, you can shrink the log files by running the batch file
runTruncateHistDBLogs.bat, installed under the wfavvid directory. Depending on the
arguments, it shrinks the log files of db_cra or tempdb.
Examples:
» Truncate the log files for db_cra to 10MB:
runTruncatedHistDBL ogs “sa” “sa_password” “db_cra all”” 10
» Truncate the tempdb transaction log:
runTruncateHistDBL ogs “sa” “sa_password” “tempdb”
Additional information can be found about truncating logs in the Managing Historical Reporting
Databases section of the Cisco CRS Administration Guide.

Note: This troubleshooting tip also applies to the CRS Database Problems section and the CRS
Historical Reporting Problems section.

CRS Server runs at 100% capacity
Symptom:
The CRS server CPU works at or close to 100 percent capacity. DTMF digits are delayed.
M essage:
None.

Cause:
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One of the following configurations might be causing this problem:
» Trace settings include debugging.

« Cisco CallManager polling is enabled. (Polling is enabled by default, but it can consume
Server resources.)

 You are running many applications on a smaller system simultaneously. For example, you
are running Cisco CallManager, Cisco CRS Server, and the LDAP database all on a low-end
MCS.

Action:
Complete the following steps:

1. Turn off debugging as a trace level option. Debugging consumes substantial server
resources. Only use debugging as a trace level option when you are actively debugging
Cisco CRS.

2. Turn off Cisco CallManager polling. Polling enables JTAPI (and therefore the telephony
applications that use JTAPI, such as CRS) to detect the addition of devices to an application
or user’s controlled list. For example, polling can detect when an agent is added to a call
center or a CTI port is added to the CRS Engine. If you do turn off polling, Cisco
CallManager does not update new devices automatically. For example, you must restart
the CRS Server after adding a new CTI port or route point to Cisco CallManager.

3. Ifyou are using a smaller system with many applications running at the same time, install
the different telephony applications on separate servers or use an MCS-7835.

Database Subsystem goes into partial service

Symptom:

The Database subsystem is in partial service when the Cisco CRS system is configured to use
a Sybase database.

M essage:

None.

Cause:

If the Sybase datasource name that you enter in the Cisco CRS Administration Enterprise
Database Subsystem Configuration web page does not match exactly the datasource name in
the Windows ODBC DSN configuration window, the database connection will fail and the

database will go into partial service.

Action:
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Be sure the Sybase datasource name on the Administration Enterprise Database Subsystem
Configuration web page matches the Windows ODBC datasource hame.

JTAPI subsystem is in partial service

Symptom:

The Engine Status area in the Engine web page shows that the JTAPI subsystem is in partial
service.

M essage:
None.
Cause

The JTAPI client was not set up properly. At least one, but not all, of the CT1 ports, route points,
or dialog channels (CMT or MRCP) could not initialize.

Action:
Complete the following steps:
1. Refer to the CRS trace files to determine what did not initialize.

2. Verify that all CTI ports and CTI route points are associated with the JTAPI user in Cisco
CallManager.

3. Verify that the Cisco CallManager and JTAPI configuration IP addresses match.

4. Verify that the Cisco CallManager JTAPI user has control of all the CTI ports and CTI
route points.

5. Verify that the LDAP directory is running on the computer specified in the Directory Host
Name field in the Directory Setup web page Configuration Setup area.

6. Verify that the application file was uploaded to the repository using the Repository Manager.

Unable to connect to JTAPI provider

Symptom:

The JTAPI provider is unavailable.
M essage:

None.

Cause:
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The problem might be caused by one of the following:

« Cisco CallManager is not running.

» LDAP Directory Service is not running.

« Incorrect JTAPI client version is installed on the CRS server.

» JTAPI user is not configured correctly.

» JTAPI client cannot communicate with the Cisco CallManager.

Action:

Depending upon the cause, do one of the following:

» Troubleshoot the Cisco CallManager (refer to Cisco CallManager Administration Guide).
» Troubleshoot the LDAP directory (refer to Cisco CallManager Administration Guide).

» Check the JTAPI version on the CRS server by selecting Start > Programs > Cisco JTAPI
> Readme.

» From the CRS Administration web page, choose Subsystems > JTAPI, click the JTAPI
Provider hyperlink, and then verify that information in the User ID field matches the name
of a valid user in Cisco CallManager. Verify that information in the Password field is correct.

« Verify that Cisco CallManager is running. Configure Cisco CallManager using the IP address
instead of the DNS name.

The Simple Recognition step takes the unsuccessful branch

Symptom:

The Simple Recognition step in a script takes the unsuccessful branch even when the word
spoken or DTMF key pressed is defined in the grammar.

M essage:

None.

Cause:

The Simple Recognition step is configured with a set of tags and output points. Most likely, the
tag names defined in the step do not exactly match the tag names defined in the grammar used

by the step. Such a mismatch can occur when a tag name is defined in the grammar

Action:
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Complete the following steps:

1. Verify that all tag names defined in the grammar are configured in the Simple Recognition
step with matching spelling and case.

2. If the grammar contains tag names that are not configured in the Simple Recognition step,

either configure the same tag name in the Simple Recognition step or remove the tag names
from the grammar.

Calling party and CRS do not have common codec
Symptom:
The calling party hears a fast busy signal when calling into a CRS application.
M essage:
The CRS log shows CTIERR_REDIRECT_CALL_PROTOCOL_ERROR.
Cause:
The calling device’s codec is possibly incompatible with CRS.
Action:

Use the transcoding service on Cisco CallManager or ensure that the calling device is using
G.711 or G729, depending on what is configured on the CRS server.

Prompts with incorrect codec being played out
Symptom:
The calling party does not hear prompts.
M essage:
None.
Cause:
The prompt being played does not match the system’s codec.
Action:

Use the correct version of the prompt.
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Prompt Exception in CRS Engine log file

Symptom:

A prompt exception appears in the Cisco CRS Engine log file.
M essage:

The exception contains the words open port failed.
Cause:

This error is generally caused when the Cisco CRS Engine is incorrectly shut down; for example,
from the Windows Task Manager while there are RTP ports in use.

Action:
If this prompt exception appears, reboot your Cisco CRS Server. To prevent this problem, stop
the Cisco CRS Engine. Choose System > Engine from the CRS Administration menu bar and

then click Stop Engine. Alternatively you can use the Windows services console to stop the
Cisco CRS Engine.

CRS Engine does not start

Symptom:

The Cisco CRS Engine does not start and the trace file contains the following message:
M essage:

Port already in use.

Cause:

If another process is using the Cisco CRS Engine default port 1099, the CRS Engine will not
start.

Action:

From the CRS Administration web page, complete the following steps:
1. Choose System > System Parameters.
2. Enter a different port in the RMI Port Number field.

3. Stop and then restart the CRS Engine.
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Application subsystem in partial service and application running for an unexpectedly long time

Symptom:

The Application subsystem is in partial service and the Application Tasks real-time report shows
an application running for an unexpectedly long time.

M essage:

None.

Cause:

If an application does not receive a disconnect signal after a call, and the application does not
have an error handling mechanism to detect that the call has ended, the Application subsystem
might go into partial service. In addition, Application Tasks real-time report might show an
application running for an unexpectedly long time.

Action:

Make sure that the application script includes error handling that prevents infinite retries if a
call is no longer present.

CRS Server and Active Directory integration results in some services being unregistered

Symptom:

Installing Cisco CRS Server into a corporate Active Directory to take advantage of a single
logon to access the DESKTOP_CFG share, instead of creating local logon account and local
permissions on the CRS Server, results in some services not being registered. For example,
when installing new product features, such as MRCP TTS, or VoIP Monitor Server, some
services might not register.

M essage:

None.

Cause:

Domain security policies can affect the installation, and some services might not get registered.
The installation appears to complete without problems.

Action:
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To correct this problem, complete the following steps:

1. Remove the CRS server from Active Directory back into a local workgroup and then
reboot.

2. Log on as the local Administrator, and then run the necessary installer CD.
3. Reboot and complete any new setup and configuration.

4. Re-add the CRS server back into the Active Directory.

CRS Real-Time Reporting Problems

The following sections describe common problems with CRS Real-Time Reporting.

Attempting to run a real-time report causes an error

Symptom:

The following message appears when you try to run any real-time report from the CRS
Administration web page:

M essage:
Unable to connect to the server.
Cause:

The proxy server setting on the Browser impedes underlying RMI communication, or the RTR
subsystem is not running.

Action:
Complete the following steps:

1. From Internet Explorer, choose Tools> I nter net Options> Connections> L AN settings
and then uncheck the Use a proxy server check box.

2. Make sure that the RTR subsystem is running.

After installing JRE, the user receives a message from real-time reporting saying to install JRE

Symptom:

Upon opening a real-time reporting applet, a message box with information about the version
of JRE that is running and the required version of JRE appears. The user installs the required
JRE version yet still gets this message when opening a real-time report applet.
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M essage:
Message contains the JRE version.
Cause:

The message appears when another version of JRE is installed on the machine as default and
is invoked at run time.

Action:

Uninstall that version of JRE from the Control Panel and reinstall the required JRE version.

CRS Historical Reporting Problems

The following sections describe common problems with CRS Historical Reporting..

Exported PDF report does not print in landscape orientation

Symptom:

A report that has been exported in Portable Document Format (PDF) does not print in landscape
orientation.

M essage:

None.

Cause:

Limitation of PDF viewer.
Action:

Print the document in portrait orientation.

User login missing in Windows XP after installing HR client

Symptom:

No user login exists in Windows XP after installing the Historical Reports client.
M essage:

None.

Cause:
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The Windows XP system hides the Administrator user icon when no other user account exists
in the system.

Action:
Do one of the following

» Restart the machine. When you see the Windows XP login screen (with the user icon turned
on), press Ctrl-Alt-Dél twice and then choose the Administrator User ID.

» Create a new user account in the XP system other than Administrator.

Charts do not appear properly in MS Excel format
Symptom:
Charts do not appear properly in a report that has been exported in Microsoft Excel format.
M essage:
None.
Cause:
Limitation of the export function.
Action:

Do not include charts in reports that are exported in Microsoft Excel format.

Columns of data missing in report in MS Excel format
Symptom:
Columns of data are missing in a report that has been exported in Microsoft Excel format.
M essage:
None.
Cause:
Limitation of the export function.
Action:

Make sure that the Extended version of Excel 7.0 is installed on the computer on which you
perform the export procedure.
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Records truncated in report in MS Excel format

Symptom:

Some records are truncated in a report that has been exported in Microsoft Excel format.

M essage:

None.

Cause:

Limitation of Microsoft Excel. Excel 7.0 (95) is limited to reports with 16,384 records. Excel
8.0 (97) and Excel 2000 are limited to reports with 65,536 records. Records that exceed these
limits are truncated in the Excel file.

Action:

Be aware of the size of the report when exporting it in Microsoft Excel format.

Agent names overwritten on charts

Symptom:

Agent names overwrite each other on charts that appear with the Agent Detail Report, the Agent
Login Logout Activity Report, or the Agent Summary Report.

M essage:

None.

Cause:

The report contains information for more than 70 agents.
Action:

Do not include charts with the report if you are generating information for more than 70 agents,
or use filter parameters to limit the report to information for no more than 70 agents.

RTF Report containing charts has tabular report headings

Symptom:

A report that has been exported in Rich Text Format (RTF) includes tabular report headings on
pages that contain charts.

M essage:
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None.
Cause:
Limitation of the export function.
Action:

Be aware of this limitation when exporting reports in RTF.

Scheduler icon does not appear on Terminal Services client

Symptom:

The Scheduler icon does not appear on the Terminal Services client when you run the Cisco
CRS Historical Reports client under a Terminal Services session.

M essage:
None.
Cause

By design, only one instance of the Scheduler can run on a Cisco CRS Historical Reports client
system.

Action:

None.

Reports do not execute at scheduled times

Symptom:

Schedules for generating reports do not execute at the expected time.
M essage:

None.

Cause:

The Cisco CRS Historical Reports client system clock has been changed but the Scheduler has
not been restarted.

Action:

Stop and restart the Scheduler. See the Cisco CRSHistorical Reports User Guide for more
information.
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Search dialog box and Preview tab appear in English on Windows system with locale set to German

Symptom:

When running the Cisco CRS Historical Reports client on a computer with an English version
of Windows for which the system locale has been set to German, the Search dialog box and the
Previews on the Report Viewer still appear in English.

M essage:

None.

Cause:

Limitation of the Report Viewer.

Action:

Install a German version of the operating system.

Dialog box does not appear as expected when report is exported

Symptom:

The Exporting Records dialog box does not appear as expected when a scheduled report is
exported.

M essage:

If the report is being exported, the following message will appear at or near the end of the file:
Note: Getting report contents may take considerable amount of time
based on the size of the contents.._Pls wait...

Cause:

This dialog box appears only after the client system fetches the required database records. For
a large report, fetching records can take a long time.

Action:

Wait for the export operation to complete. Or, check the CiscoSChPrintExport.log file.

Error when choosing an option from the Historical Reporting web page

Symptom:

An error message appears when you choose an option from a web page in Cisco Historical
Reporting.
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M essage:
Not defined.
Cause:

The Cisco CRS Node Manager service, the DC Directory Server service (or another LDAP
service), or the MSSQLServer service may not be running, or there may be a problem connecting
to the CRS database.

Action:
Complete the following steps:
1. Make sure that the Cisco CRS Node Manager service is running on the CRS server.

2. Make sure that the DC Directory Server service is running on the CRS server. Or, if you
have specified another LDAP as the active directory, make sure that that service is running.

3. Make sure that the MSSQLServer service is running on the CRS server.
4. On the CRS server, choose Start > Settings > Control Panel > Administrative Tools >

Data Sour ces (ODBC) and make sure that ODBC System DSNs dsn_cra and
DSN_SCH_DB are properly configured.

Truncated report description in Historical Reports client

Symptom:

Historical Report(s) in a localized version, such as Spanish, has the report description truncated
in the Historical Reports client user interface.

M essage:
None.
Cause

The report description seems to appear incomplete in the description box of the Historical
Reports client user interface.

Action:

Click the description box of the Historical Reports client user interface, and scroll to view the
complete localized text.

Scheduled Historical Reports do not run

Symptom:
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Historical Reports scheduled through the Historical Reports client do not run.
M essage:

None.

Cause:

The problem could be caused by an issue in the Historical Reports client schedule settings or
in the Historical Reports Scheduler connectivity.

Action:
Complete the following steps:

1. Check whether the schedules are listed in the Historical Reports client. To do this, launch
the Historical Reports client, and go to Settings > Scheduler. In the Scheduled Reports
dialog box verify that the "Daily" recurring schedules are listed.

2. By default, the "daily" schedule ends after running one occurrence. To keep them running
forever, select "No end date™ in the Schedule Configuration dialog box.

3. Check the proxy server configuration in the web browser. Open the Internet Explorer
browser and go to Internet Options > Connections> L AN settings. Check to be sure
the Use a proxy server check box is selected. If so, click Advanced and add the CRS
server to the list of exceptions.

The SQL Command Failed dialog box appears when you try to generate a historical report

Symptom:

The CRS Historical reports client computer displays the SQL Command Failed dialog box when
you try to generate a historical report. This dialog box specifies an error number, n.

M essage:

Error: <number>

Cause:

This error can occur in a variety of situations.

Action:

On the computer on which you received the SQL Command Failed dialog box, open the most

recent Historical Reports log file. Search for the error number. The cause of the error will appear
near the error number. You can use this information to resolve the problem.
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Some information appears in English on a German system

Symptom:

On a CRS Historical Reports client computer with an English version of Windows for which
the system locale has been set to German, the Search dialog box and the Preview tab on the
Report Viewer still appear in English.

M essage:

None.

Cause:

Limitation of the Report Viewer.

Action:

Install a German version of the operating system

The Historical Reports client computer cannot connect to the CRS server

Symptom:

The CRS Historical Reports client computer is unable to connect to the CRS server. The
Historical Reports Client log file shows the following message:

M essage:

Not associated with a trusted connection.

Cause:

SQL server is not being accessed with the proper authentication.

Action:
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Perform the following steps on the CRS Historical Reporting client computer:

1. Choose Start > Programs> Microsoft SQL Server n > Enterprise Manager, where n
is a version number.

2. Double-click Microsoft SQL Servers.
3. Double-click SQL Server Group.

4. From the SQL Server group, right-click the name of the server on which the CRS databases
reside.

5. Choose Properties,
6. Choose the Security tab.
7. Click the Windows only radio button.

8. Click OK.

A Database Connection Error 5051 error appears

Symptom:

When you try to log into the CRS Historical Reporting client software on the client computer,
a Database Connection Error 5051 is displayed.

M essage:

Error 5051

Cause:

Network connectivity is down or the client connection setting is incorrect.
Action:

Complete the following steps:

1. From the Windows Control Panel on the CRS Historical reports client computer, choose
Data Sources (ODBC).

2. Create a DSN to the db_cra database on the CRS server to which the client computer is
attempting to connect. Make sure the client computer and the CRS server have the same
Administrator password. While pointing the ODBC data source to the CRS server, use
<crsServerNameOr | P>\CRSSQL where crsServerNameOr | P is the named instance. For
example, if your CRS server name is CiscoCRSserverl, in the Server input box, type
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CiscoCRSserver1\CRSSQL. CRS uses NT authentication, so choose the Windows NT
authentication radio button.

3. If the DSN cannot be created, verify that network connectivity exists between the CRS
Historical Reports client computer and the CRS server.

If you are able to connect successfully using the DSN, update the hrcConfig.ini file on the
client computer with the appropriate network library.

Export file name does not appear in Export dialog box

Symptom:

A default export file name does not appear in the Export dialog box.

M essage:

None.

Cause:

If you click the Export Report tool in the Report Viewer on a Cisco CRS Historical Reports
client computer on which the language is set to Simplified Chinese, the Export dialog box will
not contain a default export file name.

Action:

The name of the report is shown on the header of the report in the Report Viewer. In the Export

dialog box, specify a name for the exported report using the report name; for example, you can
name your PDF report <ReportName>_ < startdatetime>_<enddatetime> .pdf.

Cannot point to local applications from the Database Server Configuration page

Symptom:

With a Historical Reports Database Server installed, the user cannot point to the CRS local
database from the Database Server Configuration page.

M essage:
None.
Cause:

Once a Historical Reports Database Server (remote database) is configured from Cisco CRS,
the user cannot point back to CRS.

Action:
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None. This is working as designed. To go back to a single-box solution (and lose the Historical
Reports Database Server configuration in CRS), uninstall Cisco CRS and reinstall it (and accept
the dropping of the CRS databases when prompted).

Attempt to log in to the CRS Server from the Historical Reporting client fails and an error message is returned

Symptom:

The CRS servlet service or web server is not reachable from the client machine.
M essage:

Request timed out.

Cause:

An authentication request timeout has occurred. The client log indicates Request timed out
error.

Action:
Complete the following steps:

1. On the CRS server, check to be sure the web server and servlet service are running. On
the client, check your browser Internet options for the connection setting.

2. Make sure you are able to connect to the CRS Administration web page from the client
machine. Refresh the page to make sure it is not cached.

3. Ifthe error persists after doing the above, modify your client hrcConfig.ini file by updating
AuthReqTimeOut to a larger value than the current one (default is 15 seconds).

4. Restart your client and attempt to log in again.

Only three report templates available for IPCC Express Standard

Symptom:

When configuring IPCC Express Standard for historical reporting, only three report templates
are available—IVR Application Performance Analysis, IVR Traffic Analysis, and Detailed Call
by Call CCDR.

M essage:

None.

Cause:
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The historical reporting client might not have privileges assigned to view all the IPCC Express
Standard reports.

Action:

From the Cisco CRS Administration menu, select Tools > Historical Reporting and check to
be sure the license provides eight IPCC Express reports and two VR reports.

Discrepancy in number of ACD calls shown on custom reports

Symptom:

When running user-created custom reports, one report shows the number of calls for each hour
of the day, totaling 244 calls. The other report shows the number of ACD calls for the entire
report period, totalling 243 calls. Such discrepancies happen for other days as well, the difference
being as many as four calls.

M essage:
None.
Cause

If some ACD calls are transferred, the result can be that two or more call legs fall in different
hours of the day. Therefore, the call is counted once in the first report and twice in the second.

Action:

The software is working as designed. If this is not acceptable, you could alternatively count call
legs, instead of entire calls, and the totals on the first report and the second report will match.
Then “select count distinct sessionID”” becomes “select count distinct (sessionlD, sessionSegNum)
pairs.” However, be advised that this would change the definition of counting calls for the entire
call center.

Priority Summary Activity Report chart prints only partly in color

Symptom:

The outer edges of the Priority Summary Activity Report pie chart print in color, but the middle
of the chart does not.

M essage:
None.
Cause:

This problem occurs when you print directly from the Cisco CRS Historical Report Client
Viewer and is related to the third-party printing driver from Crystal Decisions.
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Action:

Export the report to PDF output or any other supported file format and print from the output
file.

Scheduled Historical Reports do not run and message appears in CiscoSch.log file

Symptom:

If you are using a proxy service in Internet Explorer on the CRS Historical Reports client system,
scheduled historical reports might not run and you might see a message in the CiscoSch.log
file.

M essage:

[CRS_DATABASE] entry not found in the properties file. Failed to
validate user or get MaxConnections of database value.

Cause:
You are attempting to run the reports from a proxy service.
Action:

If this situation occurs but you can run the report directly from the CRS Historical Reports client
system, follow these steps:

1. From Internet Explorer on the Historical Reports client system, choose Tools > I nternet
Options.

2. Click Connections,
3. Click LAN Settings.

The Use a Proxy Service check box will be checked if you are using a proxy server.
4. Click Advanced.

5. Inthe Do not use proxy server for addresses beginning with field, enter the IP address
of the Cisco CRS server to which the Historical Reports client system logs in.

6. Click OK as needed to save your changes.

Historical Reporting Client window shows nothing in user drop-down menu

Symptom:

When selecting Tools > Historical Reporting from the Cisco CRS Administration menu,
nothing appears in the user drop-down menu.
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M essage:
None.
Cause:
Privileges have not been assigned to the CallManager user.
Action:
Assign privileges to the CallManager user who needs historical reporting privileges.

1. Log in to the Historical Reporting Client with the user name of the Cisco CallManager
user. A dialog box with a message asking if you want to set the privileges for that user in
CRS Administration appears.

2. Click Yes. The Historical Reporting Privileges page appears.

3. Assign historical reporting privileges to the user. The proper logLevel (3) is required.

Note: The User Maintenance and Historical Users pages use the same underlying directory API.

Historical Reporting Client stops working; attempt to log in again results in error messages

Symptom:

Although no changes were made to the server or network, the CRS Historical Reporting Client
suddenly stops working. When attempting to log in again, the user receives a series of error
messages.

M essage:

A series of messages appear.

Cause:

The client authentication request timed out.

Action:
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Complete the following steps:

1. On the CRS Server, check that your web server and servlet service is running. On the
client, check you browser Internet options for the connection setting.

2. Make sure you are able to connect to the CRS Administration web page from the client
machine. Refresh the page to be sure it is not cached.

3. If after successfully connecting to the CRS Administration web page the client error
persists, modify your client hrcConfig.ini file by updating AuthReqTimeOut in the General
section to a larger value than the current one (default value is 15 seconds).

4. Restart your Cisco CRS Historical Reports client and attempt to log in again.

Scheduler DOS exception error received when running a custom report

Symptom:

When running a custom report, the following error message appears in the
CiscoSchPrintExport.log file:

M essage:
ERROR Descripton=Dos error, thread in Export method=Exception.
Cause:

The DOS error can occur when the database is not accessible from the client machine at the
scheduled report time.

Action:

Schedule a report with an export format other than CSV and check the result for the same report.

Columns displaced in Excel spreadsheet when exporting a report

Symptom:

When exporting an Agent Summary Report (by agent) to a Microsoft Excel spreadsheet, the
Avg and Max statistics column headings are displaced.

M essage:
None.
Cause:

Information can be displaced if the extended Excel format is not used.
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Action:

Use the Microsoft Excel 7. (XLS) Extended format in the Export dialog box while exporting
the report to Excel. This will pop up a second dialog box. Use the default settings.

Scheduler icon does not appear in Windows status bar
Symptom:
The Scheduler icon does not appear in the Windows status bar under a terminal service session.
M essage:
None.
Cause:
This system is working as designed while running under a terminal service session.

Action:

If you need to access features from the Scheduler icon, you must do so from the computer on
which the Scheduler is installed.

Error message appears indicating connection with database is broken

Symptom:

During generation of an Agent Detail Report or an Abandoned Call Detail Activity Report, an
error message might appear indicating that the connection with the database has been broken.

M essage:

Connection with database is broken.

Cause:

This message might appear if the system is under a heavy load when either of these reports is
generated. A heavy load can include tens of thousands of calls during the report period or the
maximum number of skills configured in the system.

Action:

To work around this problem, reduce the length of the report period or reconfigure CSQs so
that there are more CSQs with fewer skills each.
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LDAP Directory Problems

The following section describes a problem with the Lightweight Directory Access Protocol
(LDAP) directory configuration for CRS:

LDAP configuration error message appears

Symptom:

During the CRS directory setup process, the Directory Setup web page displays the following
error message:

M essage:

LDAP Configuration - Error.

Cause:

The IP address or host name of the LDAP directory is not configured properly.

Action:

Complete the following steps:

1. From the CRS Administration web page, choose System > Configuration and Repository.

Verify that the information in the fields in the Directory Setup web page are correct. If
you are using a directory other than the DC Directory (for example, Netscape or Active

Directory), verify that directory is specified correctly.

2. Make sure that the DC Directory Server service running. Or, if you have specified another
LDAP as the active directory, make sure that service is running.

Automatic Speech Recognition (ASR) Problems

The following sections describe common problems with Media Resource Control Protocol
(MRCP) ASR.

Names are not recognized

Symptom:

For calls that have been allocated a channel from a MRCP ASR Dialog Control Group, names
are not consistently recognized by the Name to User step.

M essage:
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None.
Cause:

The Name Grammar Generator was not run after a new CRS installation or after you added or
changed an existing name.

Action:
Run the Name Grammar Generator.
Complete the following steps:

1. Select Tools > User Management > Name Grammar Generation. (Run the Name
Grammar Generator at off-peak times.)

2. Verify that you have select the correct Grammar Variant. If you use Nuance, select

"Nuance." If you use any other vendor, select "Standard," and in the case of a mixed
environment, select "Both."

Recognition never times out

Symptom:

While waiting for speech input, speech recognition waits indefinitely.

M essage:

None.

Cause:

This problem is caused by setting the initial timeout value to O (zero). The problem will occur
only if the ASR provider is Nuance. Nuance defines an initial timeout value of zero to mean
that it will never time out. Other vendors interpret this value to mean that it must time out
immediately.

Action:

If an immediate timeout is required, do the following: When using Nuance as the ASR software

provider, set the initial timeout value to the smallest value greater than 0 (zero). For other ASR
vendors, simply set the initial timeout to O (zero).

Alternate pronunciations and nicknames are not recognized

Symptom:

Alternate pronunciations and nicknames are not recognized in the Name to User step when used
in the ASR mode.
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M essage:
None.
Cause:

The Name Grammar Generator was not run after a new CRS installation or after you added or
changed a nickname or pronunciation in the user administration page.

Action:
Run the Name Grammar Generator.
Complete the following steps:

1. Select Tools > User Management > Name Grammar Generation. (Run the Name
Grammar Generator at off-peak times.)

2. Verify that you have select the correct Grammar Variant. If you use Nuance, select
"Nuance." If you use any other vendor, select "Standard," and in the case of a mixed
environment, select "Both."

Reduced call completion rate under heavy load while using an MRCP ASR Group

Symptom:

Under heavy load, calls that utilize a channel from an MRCP ASR Dialog Control Group, can
have a reduced call completion rate.

M essage:
None.
Cause

The MRCP channels utilized by calls can take some additional time to clean up all the sessions
set up with MRCP resources.

Action:
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Overprovision MRCP ASR Dialog Control Groups by a factor of 1.2 or by an additional 20
percent. For example, if your application requires 100 MRCP ASR channels, then configure
120 MRCP ASR channels. Complete the following steps:
1. Select Subsystems> MRCP ASR > MRCP ASR Provider Configuration.
2. Click the MRCP ASR Dialog Groups link on the left panel
3. Either click the Add MRCP ASR Dialog Control Group link or select an existing group.

4. Modify the value of Max.Number of Sessions as prescribed above. Overprovision this
value by a factor of 1.2 or by an additional 20 percent.

5. Click Update or Add as appropriate.

IMRCP ASR subsystem is out of service

Symptom:

The Engine Status area in the Engine web page shows that the MRCP ASR subsystem is out of
service.

M essage:

None.

Cause:

The cause could be one of the following: .

» The MRCP Provider and Server are not configured from the MRCP ASR Configuration web
page.

» The MRCP ASR Server(s) is down or unreachable.

» The Speech Server is not configured from the MRCP ASR Configuration web page

Action:
Complete the following steps:

1. Verify that the MRCP Provider and Servers are configured through the MRCP ASR
Configuration web page.

2. Verify that the MRCP ASR servers are up and reachable.
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Changes, additions, or deletions to MRCP ASR Providers, MRCP Servers, or Groups do not take effect

Symptom:

Changes made to either MRCP ASR Providers, MRCP Servers, or Groups through CRS
Administration do not seem to take effect.

M essage:
None.
Cause

When you make any configuration changes (including additions or deletions) to either MRCP
ASR Providers, MRCP Servers, or Groups including changes to locales through CRS

Administration, these changes are made in the LDAP and do not affect the data that is already
loaded by the engine. If you wish to make these changes effective immediately without having
to restart the engine, the changes need to be explicitly reloaded by the MRCP ASR Subsystem.

Action:

If you want the changes to take effect immediately without having to restart the engine, do the
following:

1. If you want to reload the data associated with a single MRCP Provider, Server, or Group,
go to Subsystems>MRCP ASR to access the MRCP ASR Configuration page and click
the refresh icon for the corresponding provider. You can also use this step to load a newly
created MRCP ASR Provider.

2. If you want to reload all providers, go to Subsystems>MRCP ASR to access the MRCP
ASR Configuration page and click Refresh All.

Calling a route point with an MRCP ASR Dialog Group results in default treatment

Symptom:

The customer gets the default treatment when calling a route point with an MRCP ASR Dialog
Group.

M essage:
None.

Cause:
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The cause might be one of the following:

No server is configured for this dialog group. The MRCP ASR Dialog Group refers to a
specific MRCP ASR Provider. Each MRCP ASR Provider must have at least one reachable
server configured in order to be IN_SERVICE.

None of the servers for the MRCP ASR Provider can provide all the languages required by
the MRCP Dialog Group.

Action:

Depending upon the cause, do one of the following:

Ensure that a server is configured and reachable for the MRCP ASR Provider being used by
the MRCP ASR Dialog Group.

When configuring an MRCP ASR Provider, more than one MRCP ASR Server can be
associated with that Provider. Each server can support a different set of languages. For
example, server A supports en_US and server B supports es_ES. When configuring an MRCP
Dialog Group in the Provider that contains these two servers, you are provided with a list of
Enabled Languages. For this example, the list contains both en_US and es_US because there
are servers for the specified provider that support these languages.

Normally the user interface will prevent you from selecting both en_US and es_ES for the
group because neither server supports both languages; however, it is possible to create an
illegal situation if at least one of the servers starts out supporting all the languages installed.
The Ul will allow you to select all languages for the group as well because there is at least
one server in the Provider that supports all languages. It is possible to go back to that server
and remove support for one of the languages. If you do this, the group is not changed and
now needs a language combination that neither server can provide.

To check for this, access the CRS Administration page for the group in question. Click
Update. If you see the message, There are no servers to satisfy this selection
of languages, then you need to change the languages selected to a set that is supported
by at least one of the servers in the Provider.

Text-to-Speech (TTS) Problems

The following section describes common problems with MRCP TTS.

Provider becomes IN_SERVICE immediately

Symptom:

When creating as ASR/TTS provider, its status becomes IN_SERVICE immediately. This
happens even before creating any servers for it.

Cisco Customer Response Solutions Servicing and Troubleshooting Guide 4.0(x)

129



Troubleshooting Tips

Text-to-Speech (TTS) Problems

M essage:
The ASR/TTS provider status incorrectly shows IN_SERVICE.
Cause:

After deleting a provider and all the servers along with it, if a new provider is created, it continues
to use the previous configuration and does not get refreshed.

Action:

Click Refresh or Refresh All for that provider. This will cause the status of the provider to go
OUT_OF_SERVICE as expected.

ATTS Prompt will not play

Symptom:

Callers do not hear a TTS prompt when a TTS prompt is expected.

M essage:

None.

Cause:

The cause of the problem might be one of the following:

» The language specified in the Override Language field in the TTS Prompt step is not available.

» The text referenced in the Text Input expression is larger than 20 KB.

 There are not enough MRCP TTS licenses for the MRCP TTS Provider that is being used.
Licensing can be implemented in different ways by different MRCP TTS vendors. It may
happen that depending on the licensing scheme of the vendor there may not be enough MRCP
TTS licenses configured for the language being used.

» When using multiple TTS providers, each with a different set of supported languages, the
appropriate TTS provider (the one that supports the desired language) might not get used.
This might be because the provider is not selected as the Default TTS provider and therefore
some other provider might get used.

Action:

Depending upon the cause, do one of the following:

« If the language specified is not available, from the CRS Administration web page, choose
Subsystems > MRCP TT Sand check whether the MRCP TTS server for the Override
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Language is configured. If it is not, configure a new MRCP TTS server with the desired
language and then reload the corresponding MRCP Provider.

 Text larger than 20 KB is not allowed. Make sure that you are using less than 20 KB of text.
* If necessary, obtain a license for additional MRCP TTS ports from the MRCP TTS vendor.

 Ifthe default TTS provider is not being used, configure the Default TTS Provider field using
CRS Administration. Go to System > System Par ameter sand select the desired TTS provider.
Or using the CRS Editor Create TTS Prompt step, explicitly specify the desired TTS provider
in the Overrride TTS Provider field. If using VXML scripts, specify the desired TTS provider
for Nuance Vocalizer 3.0, and the configure it as follows:

<property name="‘com.cisco.tts._provider”™ value="Nuance Vocalizer
3.0"/>

ATTS prompt is not recognizable

Symptom:

A TTS Prompt cannot be recognized by callers.
M essage:

None.

Cause:

The language of the text does not match the Override Language in the TTS Prompt step. For
example, the text is in English, but the Override Language is Spanish.

Action:

In the appropriate TTS Prompt step, make sure that the Text Input matches the Override Language
Selection.

IMRCP TTS subsystem is out of service

Symptom:

The Engine Status area in the Engine web page shows that the MRCP TTS Subsystem is out of
service.

M essage:
None.

Cause:
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The cause could be one of the following:

» The MRCP Provider and Server are not configured from the MRCP TTS Configuration web
page.

» The MRCP TTS Server(s) is down or unreachable.

Action:
Complete the following steps:

1. Verify that MRCP Provider and Servers are configured through the MRCP TTS
Configuration web page.

2. Verify that the MRCP TTS servers are up and reachable.

Long TTS prompts consume significant memory on CRS Server

Symptom:

Long TTS prompts consume significant memory on the Cisco CRS Server.

M essage:

None.

Cause:

Long text files will increase memory usage on the CRS Server. For example, a 5 KB text file
requires a 2.5 MB audio file. On a system with 40 TTS ports, this scenario can consume
approximately 120 MB of memory.

Action:

If you are using long text files, make sure to provision your system appropriately.

Non-UTF-8 characters needed for some languages

Symptom:

When using TTS for some languages, such as French or Spanish, characters are needed that are
not in the UTF-8 character set. For example: ¢, é or i if not handled correctly, will cause the
TTS server to generate an error message, and the prompt will not be heard.

M essage:

None.
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Cause:
By default, most TTS engines expect to receive characters only in the UTF-8 character set,
which are generally only those characters that are in the ASCII character set. Some characters
in languages like French or Spanish do not belong to that set, such as ¢, é or fi. When such
characters are required the script writer must specify the appropriate encoding explicitly. For
most languages, use the 1SO-8859-1 encoding, unless otherwise specified. TTS vendors document
the different 1SO encodings required by their TTS engines for different languages.
Action:

In order to specify such encoding, you must use SSML markup; therefore, you cannot use plain
text. The following example shows how character coding can be specified:

<?xml version="1.0" encoding="1S0-8859-1"?>

<speak>

Buonas tardes. Le estoy hablando en espafiol.

</speak>

This can be provided in a file or can be specified in a TTS text expression in a Workflow step.
When using the Expression Editor in the Workflow Editor, certain characters must be "escaped"”
in order to be evaluated properly. Enter the same text as follows when specified explicitly in a
text expression for TTS:

u"<?xml version=\"1_.0\" encoding=\"1S0-8859-1\""?>

<speak>

Buonas tardes. Le estoy hablando en espafiol.

</speak>

Note the use of the u"'<text string>" syntax. That allows the use of the "\" escape character

within the string to escape the quote (*) characters. You do not need to escape the non-UTF-8
characters such as the f.

A .wav file prompt playback is garbled when played by a TTS server

Symptom:

A .wav file prompt playback is garbled when played out by a TTS server.

Note: Prompts specified in VXML scripts or prompts created using the workflow

Create TTSPromptStep are played out using TTS. Such prompts can mix text with audio files.
Cisco CRS supports wave file formats with RIFF headers. For details on where prompts are
played out, see the Cisco CRS Administration Guide.

M essage:
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None.
Cause

Nuance TTS may be configured as the system default TTS provider, in which case, the wave
file prompt is played out by Nuance TTS. Nuance TTS does not support RIFF header wave
files.

Action:

Translate the RIFF header wave file into a Sphere header wave file using the utility provided
by Nuance. The utility can be found under the Nuance installation folder:

<$Nuance>V8 .5.0\bin\win32\wavconvert.exe

Changes, additions, or deletions to MRCP TTS Providers, MRCP Servers, locales, or genders do not take effect

Symptom:

Changes made to either MRCP TTS Providers, MRCP Servers, locales, or genders through CRS
Administration do not seem to take effect.

M essage:
None.
Cause

When you make any configuration changes (including additions or deletions) to either MRCP
TTS Providers, MRCP Servers, locales or genders through CRS Administration, these changes
are made in the LDAP and do not affect the data that is already loaded by the engine. If you
wish to make these changes effective immediately without having to restart the engine, the
changes need to be explicitly reloaded by the MRCP TTS Subsystem.

Action:

If you want the changes to take effect immediately without having to restart the engine, do the
following:

1. If you want to reload the data associated with a single MRCP Provider, Server, or associated
locales and genders, go to Subsystems> MRCP TTSto access the MRCP TTS
Configuration page and click the refresh icon for the corresponding provider. You can
also use this step to load a newly created MRCP TTS Provider.

2. If you want to reload all providers, go to Subsystems> MRCP TTSto access the MRCP
TTS Configuration page and click Refresh All.
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Serviceability Problems

The following sections describe common problems with Serviceability.

SNMP-based network management tools cannot monitor CRS components

Symptom:

You are unable to monitor CRS components with SNMP-based network management tools,
such as CiscoWorks 2000.

M essage:
None.
Cause:

The SNMP subagents that monitor CRS components are not loaded or configured properly, or
the SNMP service is not running.

Action:
Complete the following steps:
1. Make sure that each subagent has a key under the following SNMP service registry:
HKEY LOCAL MACHINE\SYSTEM\CurrentCortrolSet\Services\S\WP\Parareters\ExtensionAgents
2. Make sure that the subagent DLL exists under the directory specified in the registry. For
example, expect the subagent SnmpSysAppAgent to have a registry under
HKEY_LOCAL_MACHINE\SOFTWARE\ Cisco Systems,

Inc . \SnmpSysAppAgent\CurrentVersion and a path name that points to the location
of the SnmpSysApp subagent SnmpSysAppIimpl.dll.

3. Make sure that the SNMP service is running on the CRS server. If it is not, start the SNMP
service.

Large number of MS SQL Warning Messages in Event Viewer

Symptom:

There are a large number of MS SQL warning messages similar to the following message in
the Event Viewer on the subscriber node. They also occur for cra_rep_pub_ and cra_hist_pub.

M essage:

Error: 450000, Severity: 15, State: 1
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WRN craCheckLastActions : Publication (cra_agent pub) does not exist!
Cause:

The messages are logged on the subscriber node as a result of publication check (cra_rep_pub,
cra_hist_pub, cra_agent_pub publications) performed by the replication monitor.

Action:

None. Ignore the messages.

File Manager in partial service

Symptom:

File Manager is found to be in PARTIAL_SERVICE. A message similar to the following
displays in the MIVR/MADM log messages:

M essage:

Class=class.com.cisco.doc.UserDocument.Synchronization status=2005-8-7
14:02:05.36:Synching 1173: Aug 07 14:02:05.797 EDT
%MADM-FILE_MGR-6-RECOVERY_DETECTED: THREAD : EventQueue .DispatchThread-0-1:
Synchronization from Repository to local disk not performed.

Cause:

RECOVERY of the node is in progress. File Manager does not perform the synchronization of
files from RDS (DB) during recovery, and it puts itself in PARTIAL_SERVICE until it is
notified that RECOVERY is complete.

Action:

None. Working as designed.

SNMP traps do not arrive at the trap receiver

Symptom:

The network management system (NMS) does not receive SNMP trap messages.
M essage:

None.

Cause:

There is a misconfiguration in the SNMP service properties.

Action:
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Perform the following actions:

1.

On the CRS server, choose Start > Settings > Control Panel > Administrative Tools >
Services.

Double-click SNM P Services in the Name field.

In the SNMP Service Properties window, click the Traps tab and make sure that you use
the correct case and name for the community name. Also, make sure that the IP address
or host name of the trap destination is correct.

In the SNMP Service Properties window, click the Security tab and make sure that at least
one community name is defined and that its rights are READ ONLY or READ WRITE.
Do not use “public” community name as it might lead to security holes in your system.
For more information about SNMP security, refer to your Microsoft Windows
documentation. Also, make sure that you use the correct case for the community name.

On the CRS server, choose Start > Settings > Control Panel > Administrative Tools >
Servicesand verify that the SNMP service and Cisco AVVID Alarm Service are running.

On the CRS server, verify that the Cisco AVVID Alarm Service is receiving messages:

Open the AlarmService.ini file and verify that the correct port number is listed. The default
port is 1444,

Open the Alarm Service error logs, AlarmTracen.log, where n indicates the log number.
(For example, AlarmTracel1.log is the eleventh log.) By default, the error logs are in the
following folder: C:\Program Files\Cisco\AlarmService\ AlarmServiceLog.

On the trap receiver (the NMS system) make sure that the same community names are
defined in the SNMP Service properties as you used in step 4. Make sure traps are enabled
by verifying that the cvaNotificationEnable table is set to true in the ciscoVoiceAppsMIB.

Syslog messages not received by receiver

Symptom:

Your Network Management System (NMS) does not receive Syslog messages.

M essage:

None.

Cause:

There is a misconfiguration in the service properties. For more information, refer to the Syslog
Support section in Part I: Serviceability.

Action:
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Perform the following actions on the CRS server:

1. Choose Start > Settings> Control Panel > Administrative Tools> Servicesand verify
that the Cisco AVVID alarm Service is running.

2. Verify that the Cisco AVVID Alarm Service is receiving messages:

Open the AlarmService.ini file and verify that the correct port number is listed. The default
port is 1444,

Open the Alarm Service error logs, AlarmTracen.log, where n indicates the log number.
(For example, AlarmTracel1.log is the eleventh log.)

3. Verify the settings on the Syslog receiver (the NMS system).

The Alarm Service does not start
Symptom:
The Cisco AVVID Alarm service does not start.
M essage:
None.
Cause:
AlarmNTService.exe does not exist, or the alarm service is not registered.
Action:
Complete the following steps:
1. Verify that AlarmNTService.exe exists in the C:\program files\cisco\AlarmService
directory. If it does not exist, reinstall the CRS system. For installation instructions see

the Cisco CRSInstallation Guide.

2. Make sure that the Cisco AVVID Alarm Service is running. If this service is not running,
register this service by typing the following command in a command window:

C:\Program Files\Cisco\AlarmService\AlarmNTService -Service

Serviceability does not uninstall completely

Symptom:
Uninstalling Serviceability does not completely remove all serviceability components.

M essage:
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None.
Cause:
On a server on which CRS and Cisco CallManager are both installed, some Serviceability files
are shared by each of these Cisco applications. If you uninstall Serviceability, you will be
prompted for permission to delete the shared files. If you do not delete these files, they will
remain on the system.

Action:

None.

Virus Scan software slows Call Completion Rate

Symptom:

When the CRS system is under load, the system updates and writes to the log files more often.
Therefore, Virus Scan software works more often. This can affect system performance.

M essage:

None.

Cause:

Changes or updates to log files trigger the Virus Scan software to read the files.
Action:

In order to improve the Call Completion Rate of the system running under high load, the virus
scan software excludes some of the directories for performance reasons.

Exclude the following directories:

e C:\Program Files\wfavvid\log

e C:\Program Files\Cisco\Desktop\log

e C:\Program Files\Cisco\Desktop_ Audio

e C:\Program Files\Microsoft SQL Server\MSSQL$CRSSQL

CRS Internationalization Problems

The following sections describe common problems related to internationalization.

Cisco Customer Response Solutions Servicing and Troubleshooting Guide 4.0(x)

139



Troubleshooting Tips

CRS Internationalization Problems

Results not as expected for first name and last name in Chinese, Japanese, and Korean

Symptom:

First name and last name information does not produce the expected results for Chinese, Japanese,
and Korean.

M essage:

None.

Cause:

In the Cisco CRS User Options Alternate Pronunciations web page, entering information in the
First Name and Last Name fields does not produce the expected results for Chinese, Japanese,
and Korean.

Action:

To work around this problem, enter the given name in the First Name field, and enter the family
name in the Last Name field.

Language specified is not accepted or played

Symptom:

A user specifies a language, but the software does not accept it or play the language entered by
the user.

M essage:
None.
Cause:

If you are trying to use a prompt or recognition grammars, the problem might be that the language
was not successfully installed. Check the language and associated region in the 1SO 639 and
ISO 3166 standards. If the problem occurs with a Voice Browser, note that the VXML standard
specifies that languages be entered in the form xml : lang=""<1S0 639>-<1S0 3166>"
(example: en-US, fr-CA). Note that the VXML delimiter is a hyphen (-); for the CRS Editor,
Application Administration, locale customization, installation, and prompts, the separator is an
underscore ().

Action:

Check the language installation. Check the following 1SO references for the correct language
and region representation:

e |SO 639 can be viewed at:
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http://www.ics.uci.edu/pub/ietf/http/related/is0639.txt
» SO 3166 can be viewed at:

http://www.chemie.fu-berlin.de/diverse/doc/ISO_3166.html

Check to be sure you have used the hyphen (-) delimiter for VXML and have used the underscore
() delimiter everywhere else.

VXML Problems

The following section provides help with Voice XML problems.

Voice Browser Step troubleshooting steps

Symptom:

Some guidelines must be followed to avoid troubles when using the Voice Browser step.
M essage:

None.

Cause:

Not applicable here.

Action:
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To avoid problems, use the following steps:

1. Use CRS Administration to check to be sure subsystems are in service, such as CMT,
JTAPI, MRCP ASR, MRCP TTS, and Voice Browser.

2. Make sure the Universal Resource Identifier (URI) is reachable by testing the URI in a
web browser.

3. Make sure the Provider selection is set correctly.

4. 1f using VXML scripts, specify the desired TTS provider. For example, for Nuance
Vocalizer 3.0, the configuration is as follows: <property
name="com.cisco.tts._provider'value="Nuance Vocalizer 3.0"/>

5. Make sure that VXML, grammar, and audio files are correct by validating each piece
separately before connecting them all together.

6. Tracing subfacilities that are helpful in debugging the Voice Browser steps include: SS_VB,
SS_MRCP_TTS, SS_MRCP_ASR, and SS_CMT. See the Tracing chapter of this book
for additional information.

7. Make sure the file fetching locations are reachable and correct.

8. Check the syntax of the application by including VoiceXML DTD shipped with Cisco
CRS.

Timeout attribute for non-input does not work

Symptom:

The timeout attribute when set to 0 causes VXML script execution to wait forever when run
with Nuance. Nuance implements a timeout of 0 by waiting indefinitely, which is not compliant
with the VXML specification.

M essage:

None.

Cause:

Using timeout=0, for example,

<form id=""forml''><property name="timeout"'" value="0s"/> <Ffield
name="myField"> <prompt count="1"> No input expected. Say nothing
</prompt>

Action:

Using a timeout of 1 ms will effectively provide the behavior expected by the VXML
specification; that is,
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<property name="timeout" value="1ms"/>

Menu Choice DTMF does not work

Symptom:

An error.badfetch is thrown when using the menu element of Voice XML 2.0 with the DTMF
attribute set to True.

M essage:

error.badfetch

Cause:

When the menu element is set to true; that is, <menu dtmf=""true'>, then in the choice
element, DTMF values can only be *, #, or 0. For example, the following VXML code is not
allowed:

<menu id="aa" dtmf=""true''>

<prompt> Welcome to the automated attendant. To enter the phone number
of the person you are trying to reach, press 1. To enter the name of

the person you are trying to reach, press 2. To transfer to the
operator, press 0. </prompt>

<choice dtmf="1" next="#dial_by_extn">1</choice>

<choice dtmf="2" next="#dial_by_ name'>2</choice>

<choice detm="0" next="'#operator''>0,/choice> </menu>

Action:

Use an example like the following, which is allowed:

<menu id="aa" dtmf=""true'> <prompt> Welcome to the automated attendant.
To enter the phone number of the person you are trying to reach, press
1. To enter the name of the person you are trying to reach, press 2.
To transfer to the operator, press 0.</prompt>

<choice next="#dial_by_extn">1</choice>

<choice next="#dial_by_name">2</choice>

<choice dtmf="0" next="'#operator''>0 </choice> </menu>

High Availability and Failover

This section includes troubleshooting tips for CRS 4.0 high availability and failover problems.
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Previously configured log file size is not preserved after system upgrade

Symptom:

After upgrade, previously configured CRS log file size is set to default.
M essage:

None.

Cause:

The CRS log layer does not dynamically adjust the log file size after the right value synchronizes
down from LDAP.

Action:

Restart the Cisco CRS Node Manager.

Conflicts in Datastore Control Center history

Symptom:

With high availability, messages appear in the comment column in the subscription agent history.
To see the message from CRS Administration, select Datastore Control Center > History for
a subscription agent.

M essage:

A message similar to Downloaded 111 data changes (0 inserts, 111 updates,
0 deletes, 111 conflicts) appears.

Cause:

To support high availability, SQL merge replication is being used to replicate data between the
subscriber node and the publisher. As part of this, SQL logs these messages in the subscription
agent history.

Action:

No user action required.

Cannot make configuration changes in RmCm Subsystem

Symptom:

In a high availability deployment, the user cannot make changes to the configuration in the
RmCm subsystem, such as. add/remove skills, team and so forth.
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M essage:

There was an error reading/updating the database. Please contact your
administrator.

Cause

IPCC Express stores configuration data in Configuration Datastore, which is managed by the
Microsoft SQL database. The high availability databases use Microsoft Distributed Transaction
Coordinator (MS DTC) service to communicate with each other, and MS DTC service uses the
NetBIOS name of its peer to talk to other MS DTC services. This problem is caused by invalid
name resolution of the database nodes so that MS DTC cannot communicate.

Action:

Make sure the two database nodes can communicate with each other, not just by IP address,
because DTC also requires that you are able to resolve computer names by way of NetBIOS or
DNS. You can test whether or not NetBIOS can resolve the names by using ping and the server
name. The client computer must be able to resolve the name of the server, and the server must
be be able to resolve the name of the client. If NetBIOS cannot resolve the names, you can add
entries to the LMHOSTS files on the computers.

You can download DTCPing.exe from Microsoft to troubleshoot the MS DTC issue. Go to:
http://support.microsoft.com/default.aspx?scid=kb;en-us; 250367.

Service constantly shows Invalid

Symptom:

The CRS Node Manager cannot start a service, and the service is shown "Invalid" from CRS
Administration.

M essage:

A red X mark displays beside the service in CRS Administration.

Cause:

This could possibly be caused by excessive failures of the specific service.
Action:

Refer to the Cisco CRSInstallation Guide for help in doing a recovery or a restore in order to
repair the failed service.

CRS server keeps rebooting due to CRS Node Manager failure

Symptom:

The Cisco CRS server keeps rebooting due to the Cisco CRS Node Manager service failure.
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M essage:
A Microsoft Windows message shows a server reboot in 60 seconds due to the service failure.
Cause:

The problem might result from a variety of reasons, such as from failures of the CRS Engine,
CRS Administration, Datastore, and Desktop services.

Action:
Complete the following steps:

1. Go to the Windows Services Control Panel. Under the Recovery tab, change
First/Second/Subsequent failures action to Take No Action.

2. Look at the Cisco MCVD log first to identify the failure service; then go to the log of that
service to find the reason.

3. After you correct the failure, restore the failure recovery action back to First failure: Restart

the Service; Second failure: Reboot the Computer; Subsequent failures: Reboot the
Computer.

Cluster is in partial service

Symptom:

The CRS cluster status shows PARTIAL_SERVICE from the CRS Administration Control
Center.

M essage:

PARTIAL_SERVICE on CRS Administration Control Center web page under a specific server
link.

Cause:
At least one of the servers show a status that is not IN_SERVICE.
Action:

Log on to the server and see whether or not the Cisco Node Manager service is running on the
server. Also check the MCVD log for any additional information.

Server is in partial service

Symptom:

The CRS server shows PARTIAL_SERVICE from the CRS Administration Control Center.
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M essage:

PARTIAL_SERVICE on the CRS Administration Control Center web page under a specific
server link.

Cause:

At least one service is not IN_SERVICE.

Action:

From the CRS Administration Control Center web page, complete the following steps:
1. Ifaservice is not IN_SERVICE, go to the log of that service to find the reason.

2. Ifaservice ismarked Invalid, refertothetip Service constantly shows Invalid.

CRS does not accept call or function properly

Symptom:
The Cisco CRS system does not accept a call or function properly.
M essage:

From the CRS Administration Control Center, under a specific server link, there is neither CRS
Engine nor CRS SQL Server (Config/Historical/Repository/Agent).

Cause:
One possible cause could be that the component is not activated.
Action:

Go to the CRS Administration web page to activate the appropriate component.

Service Master/Slave status is not shown on CRS Administration Control Center

Symptom:

There is no Master or Slave status for a service on the CRS Administration Control Center web
page.

M essage:
There is no Master or Slave icon next to a service.

Cause:
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The problem could be caused by one of the following:
» The service is not started.
» A dependent service is not started. For example, the Cisco Desktop Service does not show
Master/Slave status unless the CRS Engine is running, and the Cisco SQL Server
(Config/Historical/Repository/Agent) does not show Master/Slave status unless the Microsoft
Distributed Transaction Coordinator or the Microsoft SQL Agent is running.

Action:

Start the dependent service.
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running for an unexpectedly long time....106

Application subsystem is in partial service....94

Attempting to start the Cisco CRS Node Manager
service causes an error 1067....92

Attempting to start the Cisco CRS Node Manager
service causes an error 1069....93

Call drops during transfer over gateway....98

Calling party and CRS do not have common
codec....104

Changes to applications do not register....97

Changing time on CRS machines results in agents
getting logged off....96

CRS Engine does not start....105

CRS Engine does not start and an RMI port in use error
appears....91

CRS Engine is running but calls are not answered...95

CRS Server and Active Directory integration results
in some services being unregistered....106

CRS Server runs at 100% capacity....100
CRS Server runs out of disk space....99
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Cannot make configuration changes in RmCm
subsystem....144

Cluster is in partial service....146
Conflicts in Datastore Control Center history....144
CRS does not accept call or function properly....147

CRS server keeps rebooting due to CRS Node Manager
failure....145

Previously configured log file size is not preserved
after system upgrade....144

Server is in partial service....146
Service constantly shows Invalid....145

Service Master/Slave status is not shown on CRS
Administration Control Center....147

Historical Reporting problems....108, 109, 110, 111, 112,
113, 114, 115, 116, 117, 118, 119, 120, 121, 122, 123

A database connection Error 5051 error appears....116
Agent names overwritten on charts....110

Attempt to log in to CRS Server from Historical
Reporting client fails....118

Cannot point to local applications from DB
configuration page....117

Charts do no appear properly in MS Excel format.109
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Columns displaced in Excel spreadsheet when
exporting a report....122

Columns of data missing in report in MS Excel
format....109

Dialog box does not appear as expected when report
is exported....112

Discrepancy in number of ACD calls shown on custom
reports....119

Error when choosing an option from the Historical
Reporting web page....112

Exported PDF report does not print in landscape
orientation....108

Export file name does not appear in Export dialog
box....117

Historical Reporting client stops working; attempt to
log in again results in error messages....121

Historical Reporting client window shows nothing in
user drop-down menu....120

Only two report templates available for IPCC Express
Standard....118

Priority Summary Activity Report chart prints only
partly in color....119

Records truncated in report in MS Excel format....110
Reports do not execute at acheduled times....111

RTF report containing charts has tabular report
headings....110

Scheduled Historical Reports do not run....114

Scheduled Historical Reports do not run and message
appears in CiscoSch.log file....120

Scheduler icon does not appear in Windows status
bar....123

Scheduler icon does not appear on Terminal Services
client....111

Search dialog box and Preview tab appear in English
on Windows system with locale set to German....112

The Historical Reporting client computer cannot
connect to the CRS server....115

The SQL Command Failed dialog box appears when
you try to generate a historical report....114

Truncated report description in Historical Reports
client....113

User login missing in Windows XP after installing HR
client....108

Historical Reporting problems....115

Some information system....115
Internationalization problems....140

Language specified is not accepted or played....140

Results not as expected for first name and last name in
Chinese, Japanese, and Korean....140

IPCC Express....14

Call Statistics, Recording, and Monitoring Server
support....14

IPCC Express problems....67, 68, 69, 70, 71, 72, 73, 74

Agent does not go to Work state after handling a
call....70

Agent or CSQ does not appear in Cisco Agent
Desktop....69

Agents, Supervisors, or Teams are out of synch....68

Agents do not appear in Resources are in IPCC Express
Configuration web page....69

Agents do not show in CSQ....73

Caller gets dropped when an attempt is made to recall
an IPCC Express agent's extension after the agent
previously parked the call....74

Calls are not routed to agents....73

Calls to IPCC Express route points are
disconnected....73

IPCC Express radio button is not available....69

Media step causes a Could not create
PlayPromptDialog Object exception....71

RM-CM remains in Initializing state....68
RM-CM subsystem is out of service....67
RM-CM subsystem remains INITIALIZING....67
Some resource selection criteria are missing....72

Unable to make any IPCC Express configuration
changes....71

Updating a NIC driver disables silent monitoring and
recording....74

You cannot select the order of agents....70
IP IVR problems....75, 76, 77
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IP IVR drops callers when transferring to an
extension....75

Prompt plays phrases in the wrong order....77
Prompts play in an incorrect language....75
Some prompts do not play....76

Some prompts in a script play in the language specified
and other prompts play in English....76

LDAP Directory problems....124

LDAP configuration error message appears....124
Media Resource Control Protocol (MRCP)....124
Real-Time Reporting problems....107

After installing JRE, the user receives a message from
real-time reporting saying to install JRE....107

Attempting to run a real-time report causes an
error....107

Remote Serviceability....13

Serviceability....9, 13, 14
About....9
Database Expansion Server support....14
Remote....13

Serviceability problems....135, 136, 137, 138, 139
Alarm Service does not start....138
File Manager in partial service....136

Large number of MS SQL warning messages in Event
Viewer....135

Serviceability does not uninstall completely....138

SNMP-based network management tools cannot
monitor CRS components....135

SNMP traps do not arrive at the trap receiver....136
Syslog messages not received by receiver....137
Virus Scan software slows Call Completion Rate..139
Simple Network Management Protocol....17
see SNMP....17
SNMP....18, 25, 26, 27, 28
Agent and Subagents....18
Basics....18

Management Information Base (MIB)....18
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Setting Community Names....27
Setting the Trap Receiver....27
Setting up Traps....26
Starting, stopping, and confirming the service....28
Trap messages....25
SNMP ....25
Traps....25
SYSAPPL-MIB....19
Trace file....40
Configuration....40
Trace files....39, 41, 42, 48, 49, 50, 51
Displaying....49
Displaying thread dump file....51
Facilities....42
Interpreting Engine Trace file....50
Level options....41
Setting trace level options....48
Subfacilities....42
Thread dump....50
Viewing and interpreting....49
Writing to thread dump file....50
Troubleshooting....61, 63, 65
general steps....63
Tips....65
TTS problems....129, 130, 131, 132, 133, 134
A TTS prompt is not recognizable....131
A TTS prompt will not play....130
Changes do not take effect....128, 134

Long TTS prompts consume significant memory on
CRS Server....132

MRCP TTS subsystem is out of service....131

Non-UTF-8 characters needed for some
languages....132

Provider becomes IN_SERVICE immediately....129
Wave file prompt playback is garbled....133
VXML problems....141, 142, 143
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Menu Choice DTMF does not work....143
Timeout attribute for non-input does not work....142
\oice Browser Step troubleshooting steps....141
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